Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my search in Windows 8. When I search through the Modern UI style (WinF) for files, it won't return a single result from none of my drives.

Searching via Windows Explorer works fine.

I had the same problem in Windows 8 Consumer Preview, but it worked in Developer Preview. And I looked on the net for other users with similar problems, but I haven't found anything.

Is there someone who knows what the problem might be?

share|improve this question
    
Just to be clear, you want to search inside indexed files, right? –  Karan Nov 3 '12 at 23:55
    
I want to search for files on my hard drives, just like in windows 7. For example, an mp3 with artist like say eminem. In win 7 i just hit the windows key and typed in eminem, it would then return every mp3 (and other fiels) with eminem in the name. Here, in win 8, it returns 0 results when doing so, in files, yet i know i have lots of mp3's with eminem –  Peter Jansen Nov 4 '12 at 0:10
    
Well they removed unified search in Win8, so this might be a casualty of that decision. –  Karan Nov 4 '12 at 0:12
    
hmm, it might be. It's just funny that it works in windows explorer and not in the metro search. I will just have to get used to searching in a new way i suppose :) - thanks anyway –  Peter Jansen Nov 4 '12 at 0:22
    
Experiencing identical difference beteen Metro-search results (Win+F) and Desktop Explorer-search results (Win+E, Search Tools box) on new HP Pavillion 23 pre-installed with Win 8 (2012). Searching for prefs.js, Metro-search finds no files. Desktop Explorer-search results in two exact matches, and other files where "prefs" and "js" occur together in the file name and the file extension. I conclude there are either bugs, or configuration settings (?where) in the Metro-search function making it faulty or incomplete. Sadly no Spotlight-equivalent Microsoft. –  Lexie Jan 1 '13 at 14:22

3 Answers 3

up vote 1 down vote accepted

I personally haven't experienced this problem.

Have you tried to choose Files when searching?

I good place to start would be to check if Windows can find indexed files. By default only files in the library directories are indexed. Have you tried to find a file in that directory?

Can you let us know what your indexing options look like? These should be visible by searching for Indexing Options and going to the menu.

enter image description here

Image Source

share|improve this answer
    
Searching for indexed files works. I have tried to index every hard drive on my computer, but i had to pause it so it hasn't completed indexing everything yet. I guess it would work, but i'm sure that everyone else can find files on there computer, without ever toughing index options. Or have the search changed radically from windows 7? –  Peter Jansen Nov 4 '12 at 0:06
    
@PeterJansen Do you consider your problem resolved? –  Mikhail Nov 4 '12 at 0:07
    
Nope, he's saying searching for non-indexed files still doesn't work properly. Also, when you ask "Have you tried to choose Files when searching?", that's what Win+F does. –  Karan Nov 4 '12 at 0:09
    
Okay, there are two 2 different issues. First, indexing overrides the default search functionality: if the index is incomplete, it won't find anything in the folders chosen for indexing, while the index is being built. Second, an indexed folder only finds certain files that are recognized types. If the OP is searching for fun.2ew if will not be found through the Modern UI search on an indexed folder. –  Mikhail Nov 4 '12 at 0:15
1  
ok. I will let it complete the indexing and see how it will turn out. But i think i will just have to get used to searching for files via windows explorer. Might even be the best solution in the end anyway. Thanks for the answers :) –  Peter Jansen Nov 4 '12 at 0:23

been over a month but I finally found the steps to fix it:

1. remove all external drives, ensure you haven't disabled any relevant services (VSS, indexing, superfetch, search)

2. remove all items from index

3. delete and rebuild index

4. advanced startup options -> troubleshoot -> command prompt

Then run the following commands:

% chkdsk /f c:\
% sfc /scannow /offlinedirectory=c:\windows /offlineboot=c:\

NOTE: (check my syntax by typing 'sfc' with no arguments)

5. reboot and enable indexing for your desired locations if you've cloned a drive (like me) you may have multiple device IDs - which will enrage windows 8 and most likely put you in 'to go' mode - which you can fix by deleting a registry key (google it) - but might also contribute to this problem. so scan all your external drives as well.

6. search should work now!

share|improve this answer

I had a similar problem. You just have to index each drive. Check all drives in Indexing Options and then click on Advanced option to rebuild it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.