Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently reinstalled my computer and decided that I want to have a native installation of Linux side by side with windows (got tired of VMWare). The thing is upon installation (Debian) everything goes fine until the disc detection section - Linux can't find my western digital 1TB drive (IDE mode).

I don't have the installation disc with me now, but I think that when I changed the mode to AHCI everything worked, though Windows couldn't boot so this is not an option.

I have a Marvell 91xx controller.

share|improve this question
    
Build the kernel :-) –  Mikhail Nov 4 '12 at 11:32
    
I'm not that much of a Linux guy (yet) :P –  Seth Nov 5 '12 at 17:04
add comment

2 Answers

Generally speaking, if you want to run both on AHCI (which you need for larger, newer drives) - you have to install after that mode is enabled.

So the unfortunate answer to your question to how do I get it to work? is that you should re-install Windows after setting the SATA to AHCI. That being said - you should notice an increase in performance on new drives (specifically decent SSDs).

I had a similar experience, and my suggestion above fixed it for me.

I did not find a way to get around it, however, that was around 5 or 6 months ago last I tried it.

share|improve this answer
1  
Windows actually supports AHCI after installing on IDE, check my solution :) –  Seth Nov 5 '12 at 17:03
    
@Seth - Thank you for that! I wish I knew that back when I tried doing it. –  nerdwaller Nov 5 '12 at 17:10
add comment
up vote 1 down vote accepted

Alright, I figured this out.

Debian installation somehow doesn't like IDE mode on the drive so i needed to go for AHCI. The thing was, Windows defaultly disables AHCI drivers after installing on an IDE drive so you need to enable them, following these steps:

  1. Open regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services
  3. Select msahci (left pane)
  4. Change value of start from 3 (or 4) to 0
  5. Reboot computer, enter BIOS and change drive mode to AHCI
  6. Windows should now boot and install any additional drivers needed

This way I was able to boot Windows and make the Linux installation detect my drive at the same time. Hopefully it installed successfully, I didn't spot a problem with any OS (except a Windows was unable to boot error after the Linux installation, though the Start Windows normally option solved it)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.