Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a nas box running some flavour of linux 2.6.31.8.nv+v2 with an arm processor.

It has got a samba share called 'all' that has full read write access to everyone. However one Windows machine cannot access it without prompting for authentication and I found out from the logs that the windows account matches a local account on the nas box. What I then went to do is delete the local account on the nas. I can see that /home,/etc/password + /etc/shadow the account doesn't exist anymore. However the samba logs, shows that it thinks it is still there as it says account is disabled. I've tried rebooting both nas + windows box. Is there somewhere else that it stores account information? I logged on with a different account on that Windows machine and I can access the share fine. The smb logs shows that it can't find the user and then allows anonymous access.

share|improve this question
    
I fixed it. Sort of.. not sure if this is the right way. I created the account user1 again. Then this time I use smbpasswd -x user1 first and then use userdel user1. –  lbanz Nov 4 '12 at 16:19

1 Answer 1

Users that are used for authenticating samba connections may or may not be the same as the users on the linux system. This depends on how samba is configured. Consult samba docs for more info on authentication and look at the samba config on your system to determine where and how it stores user information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.