Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

System: I'm on a BT5r3 image atop of VMware Fusion 5 on OSX 10.7.4

I spin up the VM, login, run startx, then hop in a terminal to run service networking start. I have just one interface configured in to bridge to my wireless network, which I'm on.

As of last reboot, I keep getting the error network stop:waiting when trying to run it. restart and stop don't help either. /etc/network/interfaces is setup just fine and even bypassing it with ifup errors:

$ ifup eth0

SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.

This has previously worked. Any recommendations on how to proceed?

Thanks, mjb

share|improve this question
up vote 2 down vote accepted

Make sure that the interface shows up when you run /sbin/ifconfig -a. If it's there, make sure the name of the device hasn't changed from eth0.

If there is no interface there, check your virtual machine settings to ensure that the bridge is still configured.

Are the vmware-tools installed?

Also remember that ifup/ifdown, /etc/init.d/networking, service only work as root.

share|improve this answer
ifconfig -a is showing eth4, 5 and 6. Does it make sense to edit /etc/network/interfaces to eth4 instead of 0? – mjb Nov 4 '12 at 22:30
I reinstalled tools just in case... and then ran dhclient. Now I'm connected. Not sure why. Correct answer goes to whomever can explain what little logic there was in my actions. Cheers. – mjb Nov 4 '12 at 22:41
Just realizing I didn't give credit where it was due! Thanks for your help. – mjb Dec 11 '13 at 14:22

If you copy the linux virtual machine (in this case is BackTrack 5 R 3 vmware version) from an external disk or from a directory to a new directory in your computer then run it at first time, there is a notification to “I Copied it” or “I Move it” . Usually if you choose “I Move it” and after entering the desktop by startx, then you’re trying to ifconfig eth0 up via terminal there is an error appears:

eth0: ERROR while getting interface flags: No such device.

That’s because the virtual machine couldn’t detect the interface and couldn’t generate the interface rule (70-persistent-net.rules) file in the /etc/udev correctly.

How to solve? It’s very simple just remove the interface rule:

root@bt:~# mv /etc/udev/rules.d/70-persistent-net.rules   /etc/udev/rules.d/70-persistent-net.rules.old

Then reboot your machine.

Try to check the interface again via terminal using : ifconfig -a , make sure there is “eth0″.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.