Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a laptop connected via HDMI to a TV which I use as the primary monitor. I have disabled the sleep function when closing the lid in the power settings and set the laptop to "only display on monitor 2" in the display settings. This works fine and allows me to just use the TV as the main display while stowing the laptop out of the way while I watch a film etc. My problem is that when it comes to open the laptop to gain access to the keyboard the display is automatically reverted to "extend these displays" making the laptop screen the primary again. This messes up whatever's on screen and also mean that I have to manual switch the TV to the primary display when it comes to closing the laptop again. Is there any way to prevent this from happening.

I understand that there are a few work arounds such as not closing the laptop lid (which I currently am forced to do) or buy a wireless keyboard and mouse to avoid having to use the built in ones (which I may well do in the future). For now I was just wondering if there was any easy way to prevent the opening and closing the laptop from altering the display settings in the same way as changing the power options prevents it from putting the laptop into sleep mode.

share|improve this question
In advanced power options set the lid close to "do nothing", see if this helps. – Moab Nov 4 '12 at 21:56
This sounds like it could be a problem with drivers released by the laptop manufacturer. What model of laptop is it? Have you reinstalled Windows on it, or are you still using the installation shipped on the laptop? – Tortoise Nov 4 '12 at 23:49
The laptop is an Acer Aspire 5739G. – A. Scott Nov 5 '12 at 1:00

You must log in to answer this question.

Browse other questions tagged .