Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I login as the build-in admin and try to change owner for a folder:

enter image description here

After I click on the Change link, I suppose to get a dialog box to enter new users, but instead, I got the following:

enter image description here

WHAT??? The folder belongs to an user associated with a Microsoft account but I removed the user already and want to clean up the left over files and folders.

share|improve this question
The 000 after the name makes me think that this showed up after running CHKDSK. If that's true, it's probably corrupted and that's why you can't change it. Try booting from a live CD or something to read it. – Mark Allen Nov 4 '12 at 22:57
when i add an user with microsoft account, it automatically added 000 at the end. eg: XXXYY_000 – Ray Cheng Nov 4 '12 at 23:15
Ah ok, fair enough then, never mind. :) – Mark Allen Nov 5 '12 at 2:31
up vote 2 down vote accepted

See if you can read the ACL on the directory with cacls. There's a good chance you'll see an entry like Everyone:(DENY)(special access:)FILE_READ_DATA or something similar right at the start that's preventing you from doing anything. Edit the ACL to remove that entry:

cacls dirname /e /r everyone
share|improve this answer
the permissions got messed up but i'm not sure how did it happen at the first place. i added the user again and remove it, the folders are also removed automatically. unlike the first time, i had to manually remove them. – Ray Cheng Nov 4 '12 at 23:21
I just get access denied.. :/ – Josh Davies Jun 18 '15 at 16:06

As an admin, this will work for you.

Take Ownership

Just like Vista and Windows 7, the latest Windows 8 also requires you to take ownership of a system file or folder before editing it. That is, if you want to modify a file or folder in Windows 8, you need to take the ownership of the particular file or folder to be able to edit it.

It's a registry tweak that adds an option "Take Ownership" to your right click menu in Windows. Should do the trick for you. Just be careful to not do it to system files that are generally OS only, or you could run into a few issues (but sounds unlikely from your situation.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .