Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Not sure what I've done wrong. Built one PC before successfully in a similar way but this one seems to be struggling.

I have the following components:

  • Mobo: ASUS P8Z68-V/Pro Gen 3 (updated to latest firmware)
  • RAM: 16GB (2 x 8GB)
  • Power Supply: corsair HX850
  • HDDs:
    • 2 x 3TB drives on the intel z68 controller
    • 1 x 128GB SSD on the Marvel controller
  • Graphics: Sapphire 7950 (not using on-board graphics)

The problem

  • I set up my 3 TB disks in RAID1
  • controller appears to recognize them fine during boot as one 2.7TB raid1 volume
  • windows setup sees two disks, both 746 GB, but will only let me install to one and appears to work fine.
  • windows appears to install fine
  • after installer reboots, I receive "windows failed to start" error referencing code 0xc000000e and "\Windows\system32\winload.exe
  • every time I do an install, a new additional "win7" entry is added to the boot menu; all lead to this error.

What I've tried:

  • updated the BIOS to the latest firmware
  • attempted to repair the install
  • tried clearing / removing raid / re-raiding drives
  • tried formatting the drives during install
  • attempted to clear the menu Of entries (can't figure out how to do that)

No matter how many times I destroy the raid array, format the disks, etc. the boot entries keep piling up. Any idea where I'm going wrong?

share|improve this question
add comment

4 Answers 4

up vote 8 down vote accepted

The answer was quite involved, so I turned it into an item that hopefully others will get some lasting use from.

Warnings / Notes Before You Start

  • You will lose all data on your hard drives during this process. Back it up if you need to.
  • If you already have your drives in a RAID configuration, you may want to delete it (again, losing all data) to follow along with this process.
  • No warranties or guarantees, etc. etc. -- worked for me, but try it at home only if you know the consequences.

How to Install Windows 7 on an Intel Z68 Chipset with Drives Larger Than 2TB

This guide will take you through the process of installing Windows 7 x64 on a new machine using the following:

  • Drives larger than 2TB in a RAID 1 Configuration (for our examples, we're using 2 x 3TB HDDs)
  • An SSD Drive
  • An Intel Z68 Chipset Processor
  • A motherboard supporting the Z68 Chipset (in my case, an Asus P8Z68-V/Pro Gen3)
  • Windows 7 Professional 64-bit
  • A USB Stick you have laying around (any size good, formatted to FAT32)

On a Good Machine: Put Intel RST Standalone Drivers onto a FAT32 USB Drive

On the New Machine: Update Your Motherboard's Firmware

  • Follow whatever your manufacturer recommendations are to obtain and flash to the latest BIOS. For the ASUS P8Z68-V/Pro Gen3, check out the download page for the motherboard. Download the latest BIOS drivers.

Create the RAID Array

(This assumes you have your PC entirely together, hardware wise, which is outside of the scope of this article)

  • During boot, when the Intel storage screen is shown, press Ctrl + I to enter the RAID setup screen
  • Follow the prompts to create a RAID1 array from your two large drives
  • At this point, the drive should be seen as their actual size (approx 2.7TB using the 3TB drives)

Adding Special Drivers to Windows 7 Setup

  • Plug your USB Drive in
  • Boot from the Windows 7 CD-ROM in UEFI mode (select the UEFI option for your dvd drive from the boot list menu -- there will be two options, one with and one without UEFI).
    • It's important that you boot from UEFI mode, as this is the only mode that can create GPT drives.
  • Choose a Custom Install (again, losing all data)
  • When you reach the screen displaying your disk drives, you'll notice they're showing the wrong size.
  • Click the "Load Drivers" button.
  • Navigate to the place on the USB drive where you have the Intel RST drivers and click OK.
  • Click Next to load the driver.

At this point, your RAID1 array should show as one large drive of 2.7 TB.

Convert the RAID Array from MBR to GPT

  • From the screen asking which drive you want to install windows on, Press Shift + F10 to bring up the command prompt
  • type diskpart to open the disk partition utility
  • type list disk to list all of the drives
  • Find the drive that is listed as the large drives and find what number it is (on mine, the large RAID volume was disk 0)
  • type select disk # (where # is the number of your large volume, e.g. select disk 0 for my example)
  • type clean. This will erase all data about the drive and ensure it is as good as a raw drive.
  • type convert gpt to convert the disk to a GPT disk from an MBR disk.
  • type exit to exit diskpart and exit again to exit the command prompt
  • Restart the computer (yes I know you're in Windows setup; no, you don't need to finish it)

Check to Make Sure the GPT Conversion Worked

  • Enter windows setup again, load the intel drivers again, and bring up the command prompt by using Shift + F10 again.
  • Type list disk. This time, check to make sure that the disk you converted has an asterisk (*) in the "GPT" column.

Install Windows

  • Open windows install from UEFI BIOS again and load the Intel driver again.
  • Your large drive should now show as unallocated space.
  • Click Advanced and click New to create new partitions.
    • You will receive a message that Windows may create additional partitions. This is good; it means that Windows is creating a GPT partition structure.
  • Install Windows to the large RAID drive's primary partition as you normally would.

Boot into Windows and Extend the Drive

When Windows first boots, it won't recognize the drive as a full 3 TB drive -- 760 GB will be left unallocated.

  • From the start menu, open "Computer Management" (shortcut: type compmgmt.msc and hit enter)
  • Go to "Disk Management".
  • Right-click your large drive structure and select "Extend".
  • Extend to fill the rest of the space.

You now have a 3TB RAID1 array fully recognized in Windows 7 64-bit.

Other Recommended Actions

  • Install the Intel RST Software from your motherboard manufacturer or the web site if you're feeling savvy.
  • Install the Intel management center as well (it's usually bundled with the RST software). This is what will allow you to use an SSD to accelerate your RAID1 array (a great feature).

References

share|improve this answer
add comment

I can explain why windows sees two disks, both 746 GB.

If you partition a drive using ancient MBR then you are limited to 2.19TiB.
3TB (probably lsomewhat less since marketing tends to round up) - 2.19TiB (due to wrap around) is about 750GB.

To avoid this you will need to partition the drives using GPT. GPT is supported by windows 7. If you use a PC with UEFI rather than a BIOS you can even boot from it. (If you have an old BIOS rather than UEFI it usually does not always work.)

If you are using the SSD as OS disk then booting should not be a problem, neither from BIOS or EUFI. After you have installed windows you can go to the disk manager, partition both 3TB drives with GPT and set up a mirrored volume on them.

(Note, leave the BIOS in AHCI mode for this. Not in RAID mode.)

[Edit]

I just saw Sathya's extension to goobers answer. Nice. :)

Test both that and mirrored volumes though. There should not be a speed difference, but that is theory. And as they say "In theory, there is no difference between theory and practice. But, in practice, there is." And that practice might even vary per chipset and driver version.

share|improve this answer
    
Hi Hennes -- is there a way to partition with GPT from within a UEFI bios? I want Windows to be installed on the 3TB RAID1 (planning to use the SSD as an accelerator for the RAID1 pair). Sounds like if I can get them properly formatted & partitioned using GPT I'd be ok? –  SeanKilleen Nov 4 '12 at 22:54
    
I do not see a need to add formatting to a BIOS or EUFI. Leaving that for the OS installation seems more logical, else your EUFI should support just about every OS (including ancient stuff like AIX). Nor did I find it in this movie of your boards EUFI youtube.com/watch?v=YiOnq2jeB1U –  Hennes Nov 4 '12 at 23:09
    
So It sounds like what you're saying is that the drives are partitioned with MBR by default? Win7 setup with bare disks is what led to this. I'm looking into how to use diskpart to achieve the desired partitioning.. Regarding AHCI mode vs. RAID mode: I have the Intel controllers set to RAID mode and the Marvel controller set to AHCI. I've since unplugged the SSD to remove it from the equation. –  SeanKilleen Nov 4 '12 at 23:14
    
If you boot win7 from a BIOS then it will setup disks as MBR. If you boot win7 from EUFI it should setup disks as GTP. These are defaults. You could change them by starting from the windows DVD, going to a command prompt with shift F10 and changing the disk with the diskpart command. Should. This is something I have never done. (I have no access to a EUFI using motherboards nor to drives larger than 2.19TiB) –  Hennes Nov 4 '12 at 23:17
add comment

This page, especially the answer by Sean showing step-by-step instructions, was brilliant! I basically followed the steps above to get my system up and running, but just wanted to add some extra info about my setup in case it is helpful for other folks.

System Configuration:

  • Gigabyte GA-H87M-D3H Motherboard updated to latest firmware v.F7
  • 2 x Seagate 4.0TB SATA HD (Model #ST4000VN000) RAID 1
  • No SSD
  • 2 x G.Skill DDR3-1600 PC3-12800 8GB RAM
  • Windows 7 64-bit Ultimate

Because of the HD size, I couldn't get Windows to install. Before continuing, please note that I wanted to install Windows on a 500 GB partition (not the entire 4 TB).

BIOS Notes (specific to my motherboard but may be helpful as hints for other MB's):

  • RAID configured as Legacy RAID ROM per manual instructions, which is similar to the instructions above labeled "Create the RAID Array"

Windows Installation Notes:

  • MB instructions says that when installing with Windows 7, there is no need to install a separate RAID/AHCI driver. I found this to be false because when I tried to install using the Windows disk without "Loading Driver" as mentioned above, my HD was split into two drives, each about 1.7 TB, instead of one 4 TB logical drive. I tried both the Intel RST Standalone driver mentioned above and the Intel RST driver provided by Gigabyte ([DVD Drive]:\\BootDrv\iRST\). Both works fine. In the end, I used the driver provided by Gigabyte. Regardless, to see one 4 TB logical drive, the instructions that mention "Loading Intel RST Drivers must be followed, regardless of whether you end up using the Intel or Gigabyte driver.

  • In the instructions, there is one point where it says to use the "UEFI BIOS again". This was a bit confusing since UEFI is a bit new to me. There are plenty of other places to read up on the theoretical background so just for practicality, it basically means when choosing the boot drive, make sure to boot off of "UEFI: DVD/CDROM". Also, make sure that when you are creating the partition that you want to install Windows on, there must be 3 partitions:

    • Partition 1 - System
    • Partition 2 - MSR and
    • Partition 3 - Primary,

    in that order. Installation should be performed on Partition 3 - Primary. In my case, since I wanted to install on a 500 GB partition, I specified 500 GB when creating the new partition. There are two super helpful pages describing How to Install Windows 7 Using the UEFI and How to Do a Clean Installation with Windows 7.

  • Once I was able to figure out the proper RAID settings, loading up the right RAID drivers, and setting up the partitions correctly, Windows would start installing. However, during one of its reboots, Windows would show the blue screen of death (BSOD) and I couldn't continue. When cruising the net, there are a lot of suggestions on what could be wrong. Basically, there isn't one specific cause since a BSOD is pretty vague. However, in my case, the only two adjustments were the following:

    • The MB was not setting the RAM to 1600MHz. To fix this, I went into the BIOS > M.I.T. > Advanced Memory Settings > System Memory Multiplier > 16. This may not be the cause of the BSOD but it's worth mentioning since memory is a commonly reported cause of BSOD. I haven't had a chance but will be running MemTest86+ to check the memory.
    • Booting up to the Windows Installation disk, I used the tools provided. Repair your computer > Use recovery tools... I tried both Windows Memory Diagnostic and Windows Startup Repair, in that order, and then the computer was finally able to reboot and complete installation successfully. Instructions at How to Perform a Startup Repair in Windows 7 were helpful for this step.

Hope someone finds this helpful and saves you a few hours of head-pounding! Thanks again to the other contributors for the help!

References:

share|improve this answer
add comment

I'm guessing you want to install Windows to your SSD and have your RAID array for your data drive. If Windows installer is not seeing this drive, and is seeing the RAID array incorrectly, then you'll need to load the correct drivers for the controllers as the first step in the installation process. It's been a while since I did a Win7 install, so I can't remember the specifics, but there should be an option early on to load additional mass-storage drivers.

share|improve this answer
    
Hi Andrew, while you're wrong about my approach (I plan on installing Win7 to the RAID1 array and accelerating that using Intel RST and 64 GB partition on the SSD) -- loading the correct drivers for the controllers seems to be the correct way to go. I guess I have to find the mass-storage drivers first. Any pointers on this would be very helpful. Thanks! –  SeanKilleen Nov 4 '12 at 22:56
    
The drivers should be supplied by the manufacturer of your controller (or motherboard if the controller is embedded). –  Andrew Cooper Nov 4 '12 at 23:03
    
so since I've updated the Asus P8Z68-V/Pro Gen3 mobo to the latest firmware, this should include the updated driver for the Intel Z68 chipset's native RAID1 support? I've updated the firmware but while the BIOS sees it correctly, windows does not. It seems I need to partition the drives using GPT -- looking into whether that would solve the problem. Was curious as to whether additional drivers at Win7 install startup would have solved it. Can't find any sort of download for this scenario.. –  SeanKilleen Nov 4 '12 at 23:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.