Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Fedora 16 - sound works fine.

I've tried to execute Pocketsphinx for some tests with voice recognition, but it depends on OSS to work. It crashes with the message:

ad_oss.c(103): Failed to open audio device(/dev/dsp): No such file or directory

I have ALSA-OSS installed but im getting the same error.

share|improve this question
    
What's the output of lsmod | grep snd_seq_oss? If there's no output, try doing modprobe snd_seq_oss. – Free Bullets Nov 5 '12 at 2:24
    
I tried with lsmod | grep snd_seq_oss but there's no output. And i tried with modprobe snd_seq_oss and there's no output too. What is happening? – user170179 Nov 5 '12 at 2:31
2  
Please add any additional information to your question by editing it, instead of posting new "answers". This is not a discussion forum. – Daniel Beck Nov 5 '12 at 7:47

For /dev/dsp to work, the actual sound driver must be loaded (check index 0 in /proc/asound/cards), and the snd-pcm-oss module must be loaded.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .