Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I really don't get it what happened. My network diagnostic command line tools 'are not recognized as a batch file or external command' in command line ( ping, netstat, trcrt...). Files are in Windows XP default folder and in Enviroment Variables path also. But I can do with normal GUI everything. I didn't use command line network diagnostic on this computer for week or more, the only unusual thing is that I installed a couple of new IDE-s to my machine ( Netbeans Ide,Eclipse Juno, ActivePython, IntelliJ Idea and Lazarus). I also have Virtualbox installed more than one month or so.

Is there any chance that Virtualbox network adapters have some conflict with my command line tools ? Or there is something else ?

OS is Windows XP SP3

share|improve this question
    
Have you tried changing to the directory the EXEs are in and running them? If they work fine, can you type set at the command prompt and copy-paste your complete path here? –  Karan Nov 5 '12 at 3:21
    
I second Karan's suggestion. If you go to c:\Windows\System32 and type commands like ping, tracert it should work. Also, if the poster could show us what his $PATH variable was set to that would be helpful. –  Richie086 Nov 5 '12 at 6:09
    
I tried ping and traceroute in command line from default directory "C:\windows\system32 "and commands do work. But I have strange problem with PATH variables, is it possible that some application delete particular PATH variable after I restart computer ? Path variables: C:\Python27\;C:\Python27\Scripts;C:\WINDOWS\system32; –  mno2014 Nov 5 '12 at 13:07
    
path set to C:\Python27\;C:\Python27\Scripts;C:\WINDOWS\system32 should not cause problems. Still, try setting it to C:\WINDOWS\system32;C:\Python27\;C:\Python27\Scripts instead and see if that helps. Also, next time you receive the error, type set in that very command prompt window and check whether the path variable has been changed to something else. –  Karan Nov 5 '12 at 16:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.