Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Windows 8 for the past few days but suddenly since a couple of days I'm not able to use my Windows Store.

Every time I try to open it, it says that my system has to be connected to internet to use the store even though my computer is connected to the internet and it is working too.

This is the message that is shown when I open my app store:

Your PC isn't connected to the internet. To use the store connect to internet and try again

share|improve this question
    
have you tried to disable your firewall? –  Taylor Gibb Nov 5 '12 at 5:23
    
Do you have a proxy? You might need to set the machine proxy. See the netsh commands here. –  ta.speot.is Jan 18 '13 at 10:39

4 Answers 4

My system did this.

Windows update has installed a new driver for you, how helpful!

Do the following to resolve. I find rolling back the drivers in Windows 8 doesn't work, so here we will un install the device, remove the software, and then reboot windows. it will find the device, install it's own drivers, and work fine... until it updates again.

Go to DESKTOP (not metro) Right click in the bottom right hand corner (invisible start button) Select DEVICE MANAGER Look for Network Adapters, and expand this. Double click your wireless card name Choose the Driver Tab Click Uninstall at the bottom if prompted, say yes you want to remove the software as well

re-boot system and it will work.

you may want to 'hide' this update from your system. post back for directions if you need them.

share|improve this answer
    
Any idea why the new driver would only disable Store access and not all internet access? –  Karan Nov 5 '12 at 15:25

If you have a new installation of Windows 8 and the Store tells you that it cannot connect to the Internet (ie. displays the above message - even though other apps can connect) make sure that your date and time are set correctly

If you do not live in the default Windows 8 time zone and so set the time zone during your initial setup of Windows 8 then you must manually set the data and time as well or it will be incorrect, and results in the above problem.

share|improve this answer
    
You're suggesting Windows Store behaves the same way a Windows domain does with respect to time synchronization? Do you have an authoritative reference on that info? –  Lizz Mar 4 '13 at 3:26

Running

WSReset.exe

worked for me.

Simply go to bottom left corner and right click.

Select search and type WSReset, the app will show up on the left.

Click this to run it and my store began working again.

share|improve this answer

I've had this problem a few times, and I found two solutions that always worked for me.

  • Download and run these two Diagnostics Troubleshooting Wizards: apps.diagcab and microsoftaccounts.diagcab (via askvg.com) (both are safe downloads from microsoft).
  • Run WSReset.exe -|- press Windows logo+S (or swipe in from bottom-right corner and tap/click "Search"), search for wsreset, right-click or press and hold on "wsreset", and select "Run as Administrator".

You should also check if the system time is correct. A lot of websites have trouble connecting if this isn't set to the right time. The best thing would be to set it to automatically synchronize with a time server, if this isn't already the case.

  1. Go to the "PC Settings" app
  2. "Time and language" --> "Date and time"
  3. Make sure "Set time automatically" is set to "On"
  4. Set the correct time zone and make sure "Adjust for daylight saving time automatically" is set to "On".
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.