Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently built a new Core i5 system with Windows 7 Professional. I had planned to hook up my TVS MSP 250 XL printer using a USB to parallel cable

Once I plug the cable in, Windows 7 recognizes it as an IEEE-1284 controller and automatically installs the appropriate driver. However, in the status window it reports the following:

"USB Printing Support -- Ready to use" "No Printer Attached -- Ready to use"

When I then go ahead and manually add the printer using the "virtual printer port for USB" I can add the printer seemingly without problem. Once finished, it appears in the Devices and Printers panel. Yet, all attempts to print on this printer fail. It appears that simply no data is sent to the printer (either by programs like word or adobe or by attempting to print a test page.

Does anybody know how to fix this?

share|improve this question
    
Have you tried selecting LPT1 as the port? –  hdhondt Nov 8 '12 at 0:24
    
yeap already tried dat! –  user975234 Nov 8 '12 at 7:02
    
USB-to-LPT cables are not very reliable. As this is a desktop PC, I would strongly suggest using a parallel port card if the motherboard does not have one. They're very cheap and work well. –  hdhondt Nov 9 '12 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.