Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I've tried the trick from Virtual PC 2007, adding the following section to the vmc configuration file:

<components>
    <host_time_sync>
        <enabled type="boolean">false</enabled>
    </host_time_sync>
</components>

Later someone suggested VPC doesn't want the components level so added this instead:

<host_time_sync>
    <enabled type="boolean">false</enabled>
    <frequency type="integer">15</frequency>
    <threshold type="integer">10</threshold>
</host_time_sync>

When I start up XP Mode (Microsoft Virtual PC) it completely ignores any of these two configuration changes and if I change the clock it's instantly reset to the host time again. I've also obviously disabled the Windows Time service but as it's not joined to a domain or set up with a source it shouldn't be involved anyway.

I need to test an application over a few midnight passes and thought the XP Mode machine would be perfect, so I didn't have to mess with my workstation clock... is there any way to get the VPC guest to not sync time with the host? This is easy in Hyper-V ;p

share|improve this question
add comment

3 Answers

You just need to shut down instead of hybernate before your changes to the vmc file take effect.

share|improve this answer
add comment

Did you make sure to add your instructions inside a <components> tag like it is shown on the Virtual PC Guy's page?

share|improve this answer
    
Yes I tried that first, didn't work - then in some MSDN forum thread someone suggested removing the components part for VPC. Which did no difference. –  Oskar Duveborn Oct 2 '09 at 14:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.