Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a pretty simple thing, I just need to turn off this 'feature' in Windows 7.

  1. You have 2 screens connected to Windows 7, extended desktop mode
  2. Turn off one of the screens
  3. Windows 7 then notices the monitor is turned off, so re-organses things so that it only has one screen.
  4. I turn that monitor back on
  5. Windows 7 does NOT put things back the way it was, needing me to right click and select 'personalise' to reconfigure extended monitors.

This is terrible.

I need to be able to turn a monitor off and on, and Windows 7 do NOTHING about it.

share|improve this question
    
Have you tried turn your lcd off ? it works with single monitor as a soft monitor turn off. Never tested with multiple though. –  Prasanth Nov 5 '12 at 12:33
    
Ahh right, thanks for the comment. This is a situation we have on site. So another person/user may simply turn the monitor off for any number of reasons. Then when they turn it back on, need a support call to fix the issue! So in this case that wont do sorry. –  adudley Nov 5 '12 at 12:38
    
Are you sure this is a "feature"? I have Windows 7 extended to 2 monitors and I can't reproduce the issue. Have you got the latest display drivers? Also check the Power Management options - maybe the actual issue is that the computer is going into sleep mode and resetting things? –  Pete Oakey Nov 5 '12 at 14:14
    
Yes, feature it is, no I can't reproduce it on my system, but is happening on other's, but it seems to depend on the 'features' of the attached monitor, which we have arriving tomorrow. See here for another discussion on it saying it's a feature: social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/… –  adudley Nov 5 '12 at 16:23

1 Answer 1

up vote 0 down vote accepted

The solution was to use a HDMI to VGA converter type box (around £20). Which disables this 'feature'

the 'feature' exists and can't be turned off as it's part of a 'greener' energy rating apparently.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.