Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop has a Hitachi HTS725050A7E, this is 500GB with 4k block size. It shipped with two partitions, a 10G recovery partition on the front of the disk and the remainder of disk space in one big primary partition for C:. I used the Win7 disk manager to shrink the main partition to 358G and booted the newest linux mint livecd.

This is where it gets weird: In the linux mint installer, when I went to create my partition, the two existing NTFS partitions are not detected.

I quit the installer and in the terminal tried sudo fdisk -l and it also does not find the NTFS partitions, instead it says the entire disk is one huge FAT partition. Bless linux mint for having TestDisk in it's repositories, i was able to quickly install that and search for the partitions. TestDisk could find them by searching but also saw the huge FAT partition. I booted back to windows and ran TestDisk there, and got completely different results. In Windows, TestDisk didn't even see any FAT partition and was able to correctly read the two NTFS partitions from the partition table without searching.

I tried an ubuntu live CD with the same results and I also examined the harddrive in all three OS using DFSee and had similar results. DFSee in windows could understand the partition table and in linux it could not. I think there must be some kind of error in the partition table that windows is covering up, or maybe the windows driver for the disk is interacting with the disk firmware in a different way than the linux driver.

So here is my question: I have two options here using TestDisk and I'm not sure which is best... I can create a backup of the partition table in TestDisk windows, boot to a linux live CD and restore the partition table from the backup. Or, in a linux live cd, use testdisk to search for partitions and try to restore the partition table that way.

Which is best, or is there a different direction I should go in? I need to have linux installed on this laptop.

update: the partition table is in MBR format.

update: I've uploaded the log file from testdisk (windows) here: You'll see in the first part after it says Analyse Disk /dev/sda then it comes up with the correct partitions. But when it starts searching it sees a FAT partition at 0/1/1.

I've also uploaded the testdisk log from linux: In this log you can see that when it starts it doesn't have the correct partitions right off, but after searching it can find them.

Finally, attached here: is the first 512 bytes of my disk (I generated with dd if=/dev/sda of=sda.img bs=512 count=1). Looking at this in a hex editor, a missing piece of the puzzle is revealed. This first disk sector has the ASCII string DENALI_DATAPLEX near the front, and a little further down it has the string Dataplex ERROR: Mem alloc failed...Write error

share|improve this question

There's a chance that your disk might be partitioned using GPT, in which case fdisk will only see the "protective MBR" with a big fake partition. Try using gdisk, or some other GPT-aware partitioning tool, instead.

share|improve this answer
Thanks Wyzard, I'll check and see if that is the case. If it is, do you think i will need to convert the disk back to use linux? – Segfault Nov 5 '12 at 13:43
No, Linux supports GPT just fine. – Wyzard Nov 5 '12 at 14:11
However, if your disk is partitioned with GPT and it has Windows installed on it, it means that your system is booting using EFI, since Windows only supports booting from GPT disks when using EFI. GRUB installation is different on a system using EFI booting (though the Mint installer will probably take care of this for you). – Wyzard Nov 5 '12 at 14:18
Thanks wyzard but I guess this is not the case. I examined the disk with gdisk and had this output: Found invalid GPT and valid MBR; – Segfault Nov 5 '12 at 17:29
up vote 1 down vote accepted

Dataplex user guideTurns out these are all sideaffects of the NVELO Dataplex cache drive installation in the laptop. When Dataplex was installed it did this munge to the partition table and fixes it with invisible driver magic in windows. We have to uninstall dataplex to use the drive from a non-dataplex aware operating system. They do not have linux drivers nor do they support any dual boot configurations, so the caching simply will not work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.