Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install FreeNAS 8.3 on some desktop-level hardware (AMD Phenom + 890FX + 16GB) and I've been unsuccessful. I initially tried using a USB stick and followed the instructions on the FreeNAS site here. Making the USB was simple as the instructions laid out, but as soon as the USB is detected (during the boot process) some text appears and quickly vanishes and my machine reboots infinitely. After trying several different was to make the USB, I tried using a DVD-ROM but again, I had the same issue as the USB stick.

This leads me to conclude that either a BIOS setting is incorrect but I have no idea which one. I've changed the BIOS to not "fast" boot per se, and I've correctly configured the boot order per USB stick and the DVD-ROM drive so I know that it's working. Have I missed anything that might be causing this problem? I'm not a FreeBSD/FreeNAS expert by any means.

share|improve this question
    
if you can, try booting your media on another machine to make sure it is ok. –  TheUser1024 Nov 5 '12 at 17:29
    
Tried out the DVD-ROM and it worked just fine in two other machines. –  osij2is Nov 6 '12 at 0:05

2 Answers 2

Nothing like stating the obvious but have you reset your motherboard back to factory defaults? Set your hard drives for AHCI and check your memory speeds. I just loaded with almost the same set-up: Phenom 945, 880FX (ASRock), 8GB, 5 drive ZFS pool and it went fine...not that this info helps you beside showing it does work.

share|improve this answer
    
Yeah, I've done the factory defaults. No-go. I did manage to figure things out so I'll add a post shortly to explain my findings. –  osij2is Dec 3 '12 at 19:52
up vote 0 down vote accepted

After being frustrated with this issue, I decided to install VMWare ESXi 5.0 to install FreeNAS 8.3 as a guest VM. I was unable to get ESXi 5 to successfully install but I was finally able to once I had to downgraded the BIOS to version 1.8 and I had to use ESXi 4.1. From what I found through Google, BIOS version 1.8 has been successful with IOMMU for virtualization and ESXi 4.1 had no problems. Once ESX 4.1 was up and running, I tried installing FreeNAS in a VM but I had more issues and reverted back to the original plan of getting FreeNAS 8.3.

I decided to recreate the FreeNAS disc but instead of using Windows 7, I used my Macbook Pro. In addition, I upgraded the BIOS to the latest version (1.15 if I recall correctly). After doing both, I was able to boot from the DVD drive.

I'm not certain what to conclude. I burned the first ISO image in Windows 7 and I was able to boot from the disc on two other machines. In any case, I managed to get FreeNAS 8.3 to install only after upgrading the BIOS and recreating a new disc to install from using Mac OSX, not Windows 7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.