Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create a user using this instructions.

But i'm still getting the login failed message. From local or from a remote machine, when i try connect.

I added the root user to the /etc/vsftp.chroot_list file just writing "root" (without quotes).

Any help?

share|improve this question
    
Did you restart the FTPd so it reread its (changed) configuration file? –  Hennes Nov 5 '12 at 17:50
    
@Hennes yes, sudo service vsftpd restart –  user35538 Nov 5 '12 at 17:52
    
Did you add the users on the server before adding them to the file? –  Oliver Salzburg Nov 5 '12 at 17:54
    
@OliverSalzburg well, what i did is adding the root user. Check my question again, I edited it. root is the user that im using to connect to this machine using ssh protocol. –  user35538 Nov 5 '12 at 17:55
1  
@user35538: You shouldn't use the root user for any login at all. And if you want to enable it to log in via SSH, why are you messing with the vsftpd config? I would strongly recommend adding a new user account and working with that. –  Oliver Salzburg Nov 5 '12 at 17:57
show 2 more comments

1 Answer

up vote 0 down vote accepted

I would advise not to allow the root user to log into your system. Depending on your system, root login may even be disabled (see PermitRootLogin for SSH).

I would assume that vsftpd does not allow root login or some other components prohibit it. You should add a new user to the system and use that for daily operations.

You can add a new user to the system using adduser

sudo adduser bob
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.