Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't access any of the Google websites (primarily) because of an "untrusted security certificate".

From what I've found, it seems that the Trusted Root Certification Authorities Store is outdated.

I found an article on TechRepublic that describes my exact problem in detail, but the only problem is that the fix he used for it doesn't work.

Does anyone know what I can do? ._.

share|improve this question
    
Have you checked your machine's date/time? Is it wrong? –  Daniel Agans Nov 5 '12 at 18:46
    
I've checked everything. I know what the problem is, and it's described in that article. I just have no idea how to fix it. –  Keith Gadberry Nov 5 '12 at 18:47
    
What operating system? And I looked at that article but don't understand how you attribute using openssl to your issue. Did you create a CA on the computer in question? –  Daniel Agans Nov 5 '12 at 18:51
    
I just noticed the title "Win7" - try hopping into certmgr.msc under "Trusted Root Certification Authority" and see if there's anything fishy in there. Hell, you should ultimately be safe to clear everything out of it assuming you don't use certificate based authentication anywhere –  Daniel Agans Nov 5 '12 at 18:53
    
Windows 7 Pro x64. I'm sorry if I'm confusing, but I have no idea how to better explain it. The issue that the author of the article was having is exactly what's happening to me. I tried downloading the update that fixed it for him, and it did absolutely nothing for me. –  Keith Gadberry Nov 5 '12 at 18:54

1 Answer 1

Since the only issue I was having was with the cert that the various Google sites were issuing me...

  • I clicked the lock at the left of the address bar and exported the certificate.
  • Then I opened certmgr.msc and imported it to Trusted Root Certification Authorities.
  • Restarted Chrome, and it worked.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.