Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've upgraded to Windows 8 some weeks ago (MSDNAA!) and today, while I was trying to run a VM, I've noticed that VT-x is disabled.

Now, Hyper-V works without problems, as I've tried emulating Win7 and WP8; but VirtualBox says that VT-x is disabled and it can't run my VM.

Just to double check, I've run Securable by GRC and the Intel utility and both says that I've got VT-x off.

Here comes the problem:
VT-x is ON in my BIOS, and it worked flawlessly before upgrading to Windows 8!

Any kind of suggestion?

EDIT: My CPU supports VT-x: http://ark.intel.com/products/52219

share|improve this question
2  
Do you have the most recent version of your motherboard's BIOS? – Breakthrough Nov 5 '12 at 19:47
    
Updated it 2 hours ago, it still says that VX-T is enabled but I can't see it in Windows – StepTNT Nov 5 '12 at 20:22
up vote 31 down vote accepted

Had same issue. I enabled the Hyper-V to test the built-in virtualization in Windows 8 and that caused the OS to report Vt-x incorrectly.

I disabled Hyper-V from the Windows features and now VT-x is enabled again.

Go to Control PanelPrograms and FeaturesTurn Windows features On or Off and then uncheck Hyper-V.

share|improve this answer
2  
weird but real. It worked for me too – David Apr 18 '13 at 20:05
5  
This isn't a bug - it's just a consequence of how Windows 8 runs on HyperV. When you enable the HyperV feature, you actually install HyperV as the host OS (hypervisor) and change your existing Windows 8 installation into a special (guest) OS running on HyperV. – Jeff Meatball Yang Jul 6 '13 at 5:29
2  
This also solved the problem for me. I feel like this should be made more obvious in Windows 8 when installing the hyper-V option. Alternately, I think the VirtualBox guys could be more clear about this potential edge case in their manual where they discuss enabling VT-x – Chris Aug 26 '13 at 20:05
1  
Oh my god, spend last 4 days looking for an answer of this strange behavour. I must have enabled Hyper-V and then forgot about it. I was trying to figure out what caused this problem. Thank you! I've also had problems with internet connectivity recently. I'll research whether Hyper-V with VirtualBox clash caused that as well. – VsMaX Sep 3 '13 at 14:19
1  
Thanks man. I checked the BIOS settings over and over again but it was Hyper-V that caused the problem. – Tom Oct 16 '13 at 9:38

First, check if VT-x enabled in BIOS\UEFI Second, disable Hyper-V:

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

Here is detailed instruction: http://druss.co/2015/06/fix-vt-x-is-not-available-verr_vmx_no_vmx-in-virtualbox/

share|improve this answer

I found this article/post on Intel's site. Given that for this person, a clean install of Windows 8 (ignoring the fact that this was before the proper release,) I would suggest doing the same.

I have seen no end of problems lately for people who upgraded, which a clean install fixed.

share|improve this answer
    
It's a clean setup – StepTNT Nov 5 '12 at 20:23
    
@StepTNT - Its entirely possible the reason you have this problem is you updated the BIOS revision. I would do a clean install just to rule it out. – Ramhound Nov 5 '12 at 21:06
    
I've got this problem before updating the BIOS, and I've updated it to try to fix it – StepTNT Nov 5 '12 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .