Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every once in a while after my laptop (Toshiba Qosmio F755-3D350, now running Window 8) wakes up, it will appear to be connected to Wi-Fi (the system tray icon will display as such) however no internet access will be available. Furthermore the tool tip will tell me that I am connected to the last network I had a connection too, regardless of whether of not this is possible (even out of range).

Nether clicking on the system tray icon, nor the button in the settings side panel, will bring up the network list. Either action is simply ignored (there is still a button click animation, but nothing happens). Thus I am stuck connected to a phantom network. Enabling Airplane mode will pop up the "Airplane mode on" message, but the icon will not turn into a little plane as usual. And toggling it back on will also pop up the appropriate message, but still no icon change. And I will still be locked out of the menu.

The only way to fix this that I have found is the good old reboot, which is obviously not a great solution. And the problem may come back later.

Has anyone else experienced this problem? Dose anyone know what causes it? And is there a way to eliminate it, or at least band-aid it without a reboot?

share|improve this question
    
The Windows 8.1 update resolved similar issues on my laptop. –  Bob Nov 24 at 6:50

2 Answers 2

I think it's a problem with the wireless card drivers. They don't seem to handle sleep and wake well. I have a self-built PC using a USB wifi dongle and it does the same thing. I reset it by manually yanking it out to reset it, which is a real pain b/c its at the back of the case. Just find a way to turn off your laptop's wireless card either using a manual switch on the case or within the OS. Better yet send Toshiba a couple of passive aggressive support requests so they'll fix their faulty driver (which they prolly won't but it's worth a shot).

PS: Airplane mode doesn't turn off or reset the card, it just turns off the transmitter.

share|improve this answer

I remember having a similar problem on my computer.

There are 3 potential solutions to your problem and 1 quick fix:

QUICK FIX: Try to enable and then disable the network adapter, follow the instructions below:

  • [Win] + X > Device Manager > Expand the Network adapters section
  • Right-click on the wireless network card > Disable > Yes
  • Right-click on the wireless network card > Enable

1) MICROSOFT WIFI DRIVERS I believe there is an issue with how windows 8 deals with the wifi drivers.

If you are using the wifi drivers that are provided by Microsoft then you should get the wifi for your laptop from the Toshiba website which I have linked below:

http://support.toshiba.com/support/modelHome?freeText=3130704

  • Go to the link above
  • Then click on 'All Drivers & Updates' Then on the right hand side
  • click on 'WIFI' and the Windows you have
  • Finally select the appropriate drivers from the list

2) BIOS Settings

In the Bios there may be an option to Disable or Enable your Wifi card.

If it is Enabled, then go ahead and disable it.

Restart and then go back into the bios and re-enable it.

3) Sleep Settings - Windows

Windows may have set the Power options to disable your wifi card when it goes to sleep.If that is the case then you need to do the following:

Disable the power saving option of the wireless network adapter

  • [Win] + X > Device Manager > Expand the Network adapters section
  • Right-click on the wireless network card > Properties > Power Management tab
  • Uncheck option "Allow the computer to turn off this device to save power" then hit OK:
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.