Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I installed openSUSE yesterday on a new partition. However, this morning, when I tried to boot up Windows Vista, it went directly to the recovery menu. I did a System Repair, and a System Restore, but it still booted up to the recovery menu. Then, I inserted the openSUSE LiveCD and deleted the openSUSE partition. But now when I try to boot up the computer, it says:

Error no active partition No bootable device insert boot disk and press any key

I really need help with this. Are Windows Vista's boot files missing? If so, how do I get them back on?

What solutions are there without me needing to do a clean reinstall? Please, any help will be greatly appreciated!

Windows Vista 32-bit

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Boot off the openSUSE disk or another Linux LiveCD and run "fdisk -l /dev/sdc" (or whatever the real device is) and then post the results here. I suspect you just need to mark the Windows partition as bootable.

share|improve this answer
    
It says: Device Boot Start End Blocks Id System /dev/sda1 1 26122 209824736 7 HPFS/NTFS /dev/sda3 29055 30401 10818560 7 HPFS/NTFS sda3 is the recovery partition, sda1 is my main widnwos partition –  Adnan Oct 2 '09 at 15:32
    
yeah, looks like partition 1 is not marked bootable, so you could try marking it bootable with the linux LiveCD and go from there. run the fdisk command without the -l ("fdisk /dev/sda"), type "a" at the prompt, press "1" for partition number, type "p" and make sure there's a * in the boot column next to /dev/sda1, type "w" to write the table to disk and exit. that's it. reboot. –  quack quixote Oct 2 '09 at 16:05
    
Yes! it worked! Thank you so much for your help, I truly appreciate it. You really made my day. Thanks agsin! –  Adnan Oct 2 '09 at 16:14
    
@carlf feel free to edit your answer to include the intructions for marking a partition bootable from my comment above. –  quack quixote Oct 3 '09 at 4:21

openSUSE overwrote your drive's MBR (probably with the GRUB bootloader), so to boot Vista again you'll need to replace it.

If the automated repair options from the Vista DVD didn't fix it, you'll need to use the commandline recovery tools on the Vista installation DVD:

  • boot the DVD
  • choose country, next, keyboard, next...
  • choose "System Recovery options" instead of "install now"
  • say "No" if it asks to repair after a search
  • deselect all lines and click next
  • choose "Command Prompt"

You want the bootrec command. Access its help with "bootrec /?".

> bootrec /fixboot
Or
> bootrec /fixmbr

This may be useful:

> bootrec /rebuildbcd

These instructions were found here; official Microsoft instructions for bootrec here

share|improve this answer
    
+1: Beaten to it! Good answer. –  EvilChookie Oct 2 '09 at 15:16
    
You may need to contact HP for instructions to access the recovery command prompt; their procedure may differ, but there's probably a way. If that doesn't work, try borrowing a Vista disc from your friendly neighborhood IT guy. –  quack quixote Oct 2 '09 at 15:18
    
Thanks. I'm gonna be getting the Vista installation files from my friend soon, and I will definitely be trying this. –  Adnan Oct 2 '09 at 15:18
    
My friend has Windows Vista Business disc. I have Home Premium on my laptop. I will still be able to use the System Repair stuff, right? –  Adnan Oct 2 '09 at 15:21
    
I'm not sure, try and see. If you can get to the commandprompt you're good -- no reason bootrec should fail. It may not let you get that far due to being the "wrong" flavor of Vista, but as long as you don't let it install it should be OK to try. –  quack quixote Oct 2 '09 at 15:24

Have you attempted to boot from your Vista installation disc? The recovery tools on it are pretty powerful, and the majority of the time it is capable of detecting and fixing boot issues all on its own.

share|improve this answer
    
I have a System Recover disc from HP, i don't have a Vista installation disc. The recovery disc just goes directly to System Recover, and does not offer any other options. I really don't want to run System Recovery and have everything on my laptop wiped clean. –  Adnan Oct 2 '09 at 15:04
    
Good point. I wouldn't want that either. Do you have any friends or family members with Vista media? You just would need to access the tools on it... nothing that would interfere with licensing, etc. Also, I'm not sure on this, but a Windows 7 RC/RTM disc might have the tools on it too, although that's just a guess. –  Matt Hanson Oct 2 '09 at 15:15
    
My friend actualyl has Vista installation files that he downloaded from MSDNAA. He will burn that for me today, so hopefully that will work. –  Adnan Oct 2 '09 at 15:16
    
Win7 uses bootrec and the same recovery command prompt, but it's probably NOT the same-exact-version. Using it on an older OS is NOT a good idea. On the other hand, this MBR can't get anymore broken, so.... –  quack quixote Oct 2 '09 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.