Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a WRT160Nv2 Cisco Linksys router running in mixed mode. Other computers can connect wirelessly to it fine, some using N some using G but all of them Windows.

I now need to connect some MacBooks wirelessly but am having trouble. The time to ping the router is highly variable, ranging from less than a millisecond to several thousand milliseconds, meaning sometimes the internet is usable and other times everything times out. This happens on two MacBooks a few generations apart. It works fine when connected via ethernet.

I also have a WAG54G2 which I have attempted to connect in order to extend the network as I know the MacBooks work with this router. Neither router has a bridging mode as far as I can tell, which means that this is unlikely to work.

When I plug the WAG54G2 into the WRT160Nv2 and then connect to the WAF54G2 with a MacBook the internet works perfectly fine on all machines until I launch Adium when the internet breaks for everyone until I unplug the WAG54G2 when after a short period of time the internet works again.

share|improve this question

1 Answer 1

I'm not too sure why your MacBook are having such flaky wireless, but I'd recommend you search for firmware upgrades for the WRT160N. Also, try putting the WRT160N to G-mode only, and see if the problem persists - it might be that the N-mode is giving problems.

Also, it sounds like you have alot of clients connected to the wireless - might want to disconnect everything but just the MacBooks, and see if that helps (or rather, narrow down the problem).

And finally, you don't need bridge mode to extend your wireless. You can set your WAG54G2 to be just purely a wireless access point alone - disable it's inbuilt dhcp server, set the WAG54G2 to have its own IP address on your network's subnet, and let it broadcast its wireless with a different name - then get your MBs to connect to that wireless SSID that you know is coming from the WAG54G2.

Good luck, let us know if you need further assistance.

share|improve this answer
    
Thanks, it was turning off the DHCP server that did it. Saved me a lot of time and money, cheers. –  ICR Oct 2 '09 at 20:39
    
Turns out it didn't work. It spontaneously worked and then stopped and went back to as per post. –  ICR Oct 2 '09 at 21:39
    
And now it spontaneously works again, without me changing anything, just continuously trying and resetting the router when it breaks. –  ICR Oct 2 '09 at 22:11
    
It currently stops the Internet working when connecting through the other router. –  ICR Oct 4 '09 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.