Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I deleted the Internet Explorer app.

Now I cant find it in the store and when I pin it, it runs like desktop application and not a metro application.

Metro app screenshot :

IE in Metro

Pinned IE app opens as follows : enter image description here

How can I get the Metro IE back?

share|improve this question
    
What do you mean by deleted? –  Xandy Nov 6 '12 at 1:20
    
@Xandy Uninstalled. –  Kang Nov 6 '12 at 1:24
    
But how would you uninstall only the Metro counterpart? I mean, to uninstall it don't you have to uninstall the desktop application as well? –  Xandy Nov 6 '12 at 1:26

2 Answers 2

up vote 2 down vote accepted

You need to set Internet Explorer as a "default program".

In the start screen type: "Default Programs", then choose "set your default programs", then select "Internet Explorer" and click "Set this program as default".

This will transform your IE into a Metro style app. If you have a pinned shortcut of IE in the start screen, it will be changed into a Metro IE tile.

share|improve this answer
    
Thanks. This fixes it. But sadly it also means cant have the app if I do not use it as 'Default Browser'. –  Kang Nov 6 '12 at 1:31
    
@Kang hence you didn't uninstall it... And no, apparently you can't use the Metro version if you have another browser as the default one (just tried with Chrome, it's strange though). –  Xandy Nov 6 '12 at 1:38
    
Yes Xandy you are right. I'll post it as another question though. i.e, 'IE metro version without making it default browser'. –  Kang Nov 6 '12 at 1:40

To get it back you may have to uninstall and reinstall Internet Explorer (which should deal with both, desktop and Metro):

  1. Press Win+X to open the power user menu, then F to open Programs and Features (or navigate to it through the Windows control panel or searching through settings).

  2. Press Turn Windows features on or off in the left side and deselect Internet Explorer 10:

    Windows Features

  3. Click OK and reboot.

  4. Afterwards repeat the operation but enabling it this time. Next to the reboot you should have both versions of Internet Explorer installed.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.