Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 8 the "Safely Remove Hardware" icon sits permanently in the System Tray even though no external drive is plugged into the computer. If you click on that icon the only clickable option is "Open Devices and Printers." Hiding this (or any other) icon causes the "Show Hidden Icons" icon to display in the System Tray. Can the "Safely Remove Hardware" icon be removed from the System Tray without hiding it? Thanks.

share|improve this question

4 Answers 4

I had a similar problem with Windows 8. When I clicked on the icon in the system tray, it displayed "Open Devices and Printers" along with three dots, like "..." underneath. All of my USB cables and devices were disconnected from my computer except the USB mouse and USB keyboard. I selected "Open Devices and Printers" and removed a device called "USB 2.0 Reader". The icon immediately disappeared.

When I restarted my computer, the operating system started to automatically re install the "USB 2.0 Reader". The icon reappeared along with the three dots. Keep in mind, there is no USB reader attached to the computer.

Instead of removing the device (Windows would just re install it again), I decided to disable it. I opened the Windows Device Manager and selected the "Disk Drives" and selected "Generic - Multi-Card USB Device". I right clicked it and selected "Disable". The icon immediately disappeared.

I restarted my computer and the icon did not reappear. The device still shows up in the Device Manager, but it is disabled. The keyboard and mouse continue to work and I can connect my Windows phone to my computer.

It isn't clear what the root cause is, but I was able to remove the icon, stop Windows from re installing it, and if there is a problem in the future, I can always enable the device again. Also, this allows other "actual" devices to be connected and display the icon in the system tray (the true intention of the notification icon).

Hope this helps!

share|improve this answer
    
It did help! For me this was caused by a memory card reader plugged into the ExpressCard slot. Unplugging it, or disabling the "USB Mass Storage" device corresponding to it, made the tray icon disappear. Would have been much nicer if the icon only appeared when there was a memory card inserted and mounted! –  romkyns Jan 12 '13 at 10:39

One way to remove it is to right-click the Notification area, and select Properties. Under the Notification area heading, click Customize.

Find the Safely Remove Hardware icon and select Always hide in the Behavior column next to it. (Press OK and Apply to back out.)

share|improve this answer
5  
But does he really want this? I think he still wants to have the icon when something is plugged in. –  Caleb Jares Nov 6 '12 at 6:12

If any of your virtual drives are open the icon seems to be open in systray. Open devices and select the virtual drives and remove them from the devices and the icon from systray will go off.

share|improve this answer

In my case I managed to solve it by disabling the virtual SCSI drive that Alcohol 52% has installed on my computer. For some reason Windows detects it as an external drive or something and then displays the "Safely Remove Hardware" icon with the three dots (...) in the context menu. When I disable it in the device management screen, the icon goes away.

So that's what solved it for me. I hope someone may find this of any use when they come across my answer. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.