Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Windows 8 on one of my four primary partitions. I had two partitions for Windows 7 (boot and os), one for the Windows System Recovery Environment and the last for Ubuntu. I was often using Ubuntu, but after the installation of Windows 8 Pro I couldn't boot in it because it needed the reinstallation of GRUB2. So I thought to do it by Terminal in a live cd; but when I tried to boot the Live CD, it booted me Windows 8 Pro. This is a problem of UEFI, Secure Boot or my BIOS? It didn't happen never before now. And if it's a problem of Secure Boot, how to disable it? Thanks in advance, Sho.

share|improve this question
If you figured out the problem yourself, please post your own answer and then mark it as the accepted answer. This will denote the question as being answered. – nhinkle Nov 9 '12 at 17:43

Since the computer used to be running Windows 7, it's not even clear if the computer supports UEFI, much less Secure Boot.

As I read it, the computer is bypassing the Linux emergency CD in favor of booting from the hard disk. This can happen because the firmware is set with a boot order of hard disk and then CD. If this is the cause, it can be overcome by locating the firmware's boot order option and changing it to favor a CD boot. Another option is to press a function key (usually F8, F10, or F12) during boot to enter a boot menu that enables you to select the boot device. You should then be able to boot from your CD even if the computer normally boots from the hard disk first.

share|improve this answer
The problem is that even if, pressing Escape, I get into the boot screen, I select P1 - HP [blah blah] but it boots me HDD... – shoyip Nov 7 '12 at 20:52
up vote 0 down vote accepted

I'm very sorry. I can boot CDs and USB: crunchbang and debian CD weren't working, but the others were booting.

Anyway thank you for answering and giving me some help.

share|improve this answer

Normally this is caused by Secure Boot AND UEFI. You might need to go into your UEFI bios and set it to legacy mode until you fix Ubuntu's GRUB2. This should switch it to the old type of BIOS and disable Secure Boot, but the feature might not be available on all motherboards.

share|improve this answer
I tried to go on BIOS Settings (F10 for me) and it's the same as before (when I wasn't using w8pro) – shoyip Nov 6 '12 at 16:47
The point is that there should be a setting inside it to switch it to a non-UEFI version. – Raziel Alphadios Nov 6 '12 at 16:50
I don't see any difference and no UEFI setting... – shoyip Nov 6 '12 at 17:58
You don't need to disble UEFI, you need to disable Secure Boot, there is no reason to disable UEFI ( didn't even know that is possible ). – Ramhound Nov 6 '12 at 20:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .