Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set the Windows sound scheme to No Sounds and I still hear some beeps on certain actions. Is there a way to turn off these beeps too?

share|improve this question
1  
Coming from the sound card, or from the system speaker? –  jan Jul 16 '09 at 9:47
    
System speaker. –  tjrobinson Feb 5 at 16:01
add comment

7 Answers 7

I've found this blog post which suggests:

Start > Run > sc stop beep && sc config beep start=disabled

I couldn't test it myself but it should stop the beep and also disable the beep service permanently (or at least until you re-enable it), so there's no need to run it every time or set up a .bat file.

share|improve this answer
1  
This indeed works - stops the service now and disables it from running on next boot. –  Piskvor Jul 16 '09 at 8:50
1  
"The option name includes the equal sign. A space is required between the equal sign and the value." The second one should be sc config beep start= disabled and it's working. –  Shadow Wizard Dec 20 '12 at 13:07
add comment

For a GUI approach:

Start -> Run -> devmgmt.msc [Enter] -> View -> Show hidden Devices.

then in the window:

Non-Plug and Play Drivers -> Beep -> Disable.

There is also the option here to keep it like this permanently when you restart, which I think the net command will not do.

share|improve this answer
    
It's worth adding that this may require a reboot before it works –  tjrobinson Jul 16 '09 at 8:29
1  
Non-Plug and Play Drivers isn't on the list in Windows 8 –  Barış Uşaklı Mar 8 at 23:41
add comment

start -> run -> net stop beep

share|improve this answer
    
This works but I think you have to run it every time you restart. If you put "net stop beep" in an empty text file called "something.bat" and then put a shortcut to it in your startup folder on the Start menu then it will always run. You can edit the shortcut to make it run minimized. –  tjrobinson Jul 16 '09 at 8:25
1  
If you want it this way every time you restart your PC, I think it's better to just disable the service like you suggest in another answer ;-) –  fretje Jul 16 '09 at 9:36
add comment

If you're on Windows XP you can use TweakUI:

  1. General
  2. Settings
  3. Uncheck: Beep on errors
share|improve this answer
add comment

If you're on vista, open the Volume Mixer Dialogue box in the bottom right corner of the start bar and set Windows Sounds to Mute. You have to right-click it and manually select Volume Mixer as opposed to double clicking the speaker.

share|improve this answer
add comment

I actually had an issue where beeps were coming from my keyboard and my media keys, in particular the mute button played a short beep, kind of defeating the purpose when I wanted to shut my PC up.

I looked everywhere for a solution, and finally stumbled across the option when I was tinkering around with my bios settings, where there was a simple option to turn off keyboard beeps. Make sure to check there if the OS options are being ignored, especially on a notebook or other PC without an internal PC speaker.

share|improve this answer
add comment

From Annoyances.org

I have found the easiest way to turn off the annoying system beep in Windows XP when adjusting the volume, is to use method 3, as suggested by fester here

By following the following steps, you can turn off the beep without having to reboot.

The steps are;

  1. Right-click on My Computer
  2. On the Hardware tab, click on [Device Manager]
  3. On the "View" menu, select "Show hidden devices"
  4. Under "Non-Plug and Play Drivers", right-click "Beep"
  5. Click "Disable"
  6. Answer [Yes] when asked if you really want to disable it
  7. Answer [No] when asked if you want to reboot
  8. Right-click "Beep" again.
  9. Click "Properties"
  10. On the "Driver" tab, set the Startup type to Disabled
  11. Click [Stop]
  12. Click [OK]
  13. Answer [No] when asked if you want to reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.