Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Happens everytime I want to attach file to an email in Mail app or browse photos in Photos app (I'm not using too many apps so I can't tell whether these two are the only ones). There is something like Modern UI Explorer in which Google Drive folder is not visible. Other folders are shown. In a classic desktop Windows explorer Gdrive folder is visible.

Thanks for help in advance.

share|improve this question

5 Answers 5

up vote 2 down vote accepted

Windows Store applications, generally speaking, are only going to display files found in your libraries by default.

For example, the Photos application only shows photos in the Pictures library, SkyDrive, and other cloud enabled services:

Show photos and videos from

Simply add your Google Drive folder to the Pictures library, and it will show pictures found there in the Photos application. Here are directions for modifying Windows 8 Libraries.

When adding an attachment in the Windows Mail application, the default location to select files from is the Pictures library. To select a different file, click or touch the Files dropdown:

Files selection in the Windows Mail attachment screen

From here you can navigate to your Google Drive folder and select the file you wish to attach.

Other applications will have to be dealt with on a case-by-case basis, so post new questions if you have any.

share|improve this answer

Another option is to add Google Drive as a new Library if like me adding Google Drive to your documents library will cause duplications.

  1. Right-click "Libraries" in the left-hand navigation pane in Explorer and select New > Library

  2. Right-click your new library and select "Add..." and select your Google Drive folder (Usually C://Users//Google Drive).

  3. In Windows Mail attachments click "File" and select "Documents" from the dropdown

  4. Click "Go Up" to the main libraries list and select your custom library.

Hopefully Google will release a Metro App so you can simply click an icon similar to SkyDrive

share|improve this answer

I think I have a better answer...

I found that the problem is with the way Win8 recognizes file folders in the "Metro" interface. Try to replicate what I did:

  1. In Desktop mode, navigate to your ACTUAL GDrive location (usually ../USER/Google Drive)
  2. Right-click, and select "Properties"
  3. Click the "Customize" tab
  4. Change the "Optimize For" selection from "Documents" to "General Files"
  5. Apply/OK

Screenshot

After doing that, I found directly afterward that I was able to see the GDrive directory in both the Music and Video Metro apps.

Bear in mind that I installed my GDrive folder to the ../USER/My Documents/ directory. I also used the "temp" folder in the screenshot - I used it for example purposes only.

Would be very curious to see if this works for you or anyone else.

share|improve this answer

Since I added Google Drive folder to Documents library, I was shown Google Drive folders in Metro apps' file browser along with the hordes of folders Outlook and some other applications create in My Documents folder.

Although I would notice that the folders within the Google Drive which I have "shared" with one or more people are still hidden.

TLDR; Shared folders (in the Google Drive) doesn't respect @cowgod's hack.

share|improve this answer

I opened the Customize tab on my Google Drive properties area, and I checked on the box that says "Also apply this template to all subfolders", because it already was on "General Items"

After doing this, the option to attach Google Drive folders appeared in the metro tiles area.

share|improve this answer
    
This was already suggested by Sparky who provided a great deal more detail then you did. –  Ramhound Jan 16 '13 at 19:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.