Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed windirstat on my Windows 7 64bit Lenovo laptop to gauge where my disk space was going, for some reason "program files x86" would be listed twice, windirstat would freeze before completing the scan (due I'm sure to it trying to scan the same folder twice at the same time) I uninstalled and then reinstalled windirstat, even using a portable version from portable apps, it still listed the folder twice and would still freeze.

so I tried some alternatives like scanner and space sniffer and a few more, the weird thing with these is that they wouldn't show any program folders at all, not even x86, they all showed that my HDD took up a total of 3gigs! (its really closer to 150 out of 750)

so I'm at a total loss, any help greatly appreciated, thank you

****UPDATE: I have since tried an app called folder-size which is showing an x86 folder in an x86 folder on and on for infinity! I'm getting worried now, any ideas??

share|improve this question
2  
Hope you've not configured it to follow junction points? –  Karan Nov 6 '12 at 18:41
    
i didn't on the first few times, then i did to see if it made a difference, but it didn't. also, the other apps can't see any program or windows, users folders at all. any ideas?? –  Jayo Nov 6 '12 at 20:43
    
Did you try right-clicking and running them all as admin? –  Karan Nov 6 '12 at 20:45
    
yes, every one. the thing is that on my old laptop, which was 32bit win7 they all worked flawlessly, could that be the issue? –  Jayo Nov 6 '12 at 20:48
    
Nope, WinDirStat seems to work fine without admin access on Win7 x64 here. –  Karan Nov 6 '12 at 20:57

3 Answers 3

I had a similar issue with anti-virus software when Windows 7 (32-bit) was new. It's all about the new links that Windows 7 creates for the older programs.

Links are in fact nothing new and were available in earlier versions of Windows, but weren't used that much. (DOS Prompt --> SUBST, MKLINK)

MKLINK available since VISTA SUBST goes back to DOS 4.0 (anybody?)

Symbolic links are widespread in Linux (you can find them with 'ls -lash') and are often used to redirecct file versions. e.g. libssl9.so will point to libssl10.so and so forth so that older programs will still work when trying to find older required file names.

But I'm disgressing.

So in Windows 7 it has arrived full force. You will find a lot of these redirects/links/symbolic links in your C:\Users\ directory if you turn off the option "Hide protected operating system files (Recommended)" in the "Organize | Folder and Search Options" in the "View" register in Windows Explorer. These links are created and administered by the Windows SYSTEM and should not be modified or deleted.

The problem I had with my anti-virus software vanished with the newer version of the softwaer and other programs have followed suit.

At our company we rely on the commercial software product "TreeSize Professional" from JAM Software running with the Administrator token (Runas Administrator). You can download a 30-day trial from their website.

You just disable the option "Follow Mount Points and External Symbolic Links to Directories" and you have a nice overview of your disk.

Hope this helps.

share|improve this answer
    
You might be having a problem with the symbolic link itself. If you display all Hidden System Files as described above, you might see mutlitple Program Files(x86) under your root (C: Drive). When a program comes along and tries to access Program Files(x86) it is in fact accessing the symbolic link which points to the real Program Files(x86). Just before it is about to access the real Program Files(x86) the system says, hey try my (symbolic link) Program Files(x86) and you're off on a wild ride. –  hot2use Nov 14 '12 at 9:31
    
Open a DOS prompt and type in the following commands: cd \ <ENTER> dir /A<ENTER> You will get a list of directories in the root. See if one of them is of the type JUNCTION. You might then be able to rename the JUNCTION to something else. –  hot2use Nov 14 '12 at 9:34
    
Hey, Thanks for helping, I tried the commands and like some of the apps I mentioned, even windows is not showing any program folder at all, not x86 nor regular? nothing listed as junction either? :\ –  Jayo Nov 14 '12 at 20:01
    
that is strange. you are in C:\ and using dir /a as the command? Because even when my user (non-adminstrator) runs the command I get the junction point for the German directory C:\Programme which looks like: 04.11.2011 17:17 <JUNCTION> Programme [C:\Program Files] –  hot2use Nov 15 '12 at 8:39

Both windirstat and scanner work just fine on my Windows 7 64bit.

Your problem is probably a disk error in the directory structure of the disk, that has created a cyclic structure that causes these programs to cycle eternally.

You could try running chkdsk /f on the C drive to see if it can correct the error. Mind your backups first, since by fixing the problem it just might render the system unbootable.

But if this cannot fix it, then reformatting the disk and reinstalling Windows is the only solution to the problem. I remark that I once had a similar problem on a computer, but I preferred in that case leaving the problem as-is until I changed computers.

share|improve this answer
    
does this cyclic error cause windows to show more HD space being used than actually is? other than making it difficult for apps like WinDirStat to gauge space used, is it a problem for the regular functioning of the OS itself? thanks –  Jayo Nov 10 '12 at 18:38
    
A cycle will cause the directories in the cycle to be added indefinitely. If the software concerned has a built-in recursion limit, then it will stop after some time giving an enormous value. Otherwise it will either loop indefinitely or just abandon this folder. –  harrymc Nov 11 '12 at 8:08

Try Directory Report. It does not follow reparse points. Be sure to run it as an administrator.

share|improve this answer
    
Tried your suggestion but the app crashes after selecting "free trial" on launch, thanks for trying to help all the same –  Jayo Nov 10 '12 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.