Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a benchmark of a Python script that uses pyCUDA. Each data point is one Python instance, and a Python instance might call a CUDA kernel fewer than five times, in these cases.

The red plots show the benchmark when lightdm is stopped, and the blue dots when it is running. The vertical axis is seconds. I would have expected the performance to be lower with lightdm running. System is Ubuntu 12.04 with a GeForce 460. Any ideas? Thanks

benchmark

share|improve this question
1  
Are you using the proprietary drivers? make sure 'Preferred Mode' is set to 'Prefer Maximum Performance' under PowerMizer settings(nvidia-settings). –  page4096 Nov 6 '12 at 19:33
    
Oddly nvidia-settings tells me the driver is not running. I have run nvidia-xconfig, as sudo. jockey-text -l shows xorg:nvidia_experimental_304 - NVIDIA accelerated graphics driver (experimental beta) (Proprietary, Enabled, In use) –  Peter Becich Nov 7 '12 at 6:33
    
Same result with the regular driver in use: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use) –  Peter Becich Nov 7 '12 at 6:50
    
By default the proprietary driver will downclock the GPU to save power and maybe it doesn't switch to a higher clock when there is no OpenGL context present or similar. I would try installing a driver manually (when the installer asks something about DKMS select no, or it fails to install on Debian 6, not sure about Ubuntu). –  page4096 Nov 7 '12 at 12:25
    
Turns out that when nvidia-settings is forwarded over SSH, it will always say the NVidia driver is not running. Works fine when not working over SSH. So I've changed the setting. Thanks! –  Peter Becich Nov 12 '12 at 4:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.