Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ATI Sapphire Radeon HD5830, and I successfully installed the AMD control panel on Linux Debian Wheezy.

When I use lspci -vs 04:00.0 I get this output:

04:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cypress LE [Radeon HD 5800 Series] (prog-if 00 [VGA controller])
Subsystem: PC Partner Limited Device e177
Flags: bus master, fast devsel, latency 0, IRQ 77
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at fbcc0000 (64-bit, non-prefetchable) [size=128K]
I/O ports at c000 [size=256]
Expansion ROM at fbca0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: fglrx_pci

As you can see it only gives 256 MB of video RAM. But when I open AMD CCC it says that I have 1024MB memory, which is also the amount of memory the graphic cars is supposed to have.

I also can't use the 1024MB, because when I open Virtual Box I can only give 128 MB to the guest OS.

My xorg.conf looks like this, where I tried to manually set the memory, but that also didn't work:

Section "Device"
    Identifier  "aticonfig-Device[0]-1"
    Driver      "fglrx"
    VideoRam    1048576
    BusID       "PCI:4:0:0"
    Screen      1
EndSection

How do I solve this so I can access all the memory from my Graphics Card?

Any help would be greatly appreciated!

share|improve this question

1 Answer 1

up vote 3 down vote accepted

That 256M doesn't represent all the card's RAM, it represents a range of memory addresses used for transferring data to and from the card through the PCI bus. The video card has its own processor running its own software, so it can move data between that area and other areas of its RAM that aren't exposed through PCI.

A modern video card isn't just a dumb display device that depends on the main system to write pictures into its memory. It's really a whole separate (specialized) computer that manages its own resources for the most part.

share|improve this answer
    
So there is no problem at all, just a misunderstanding from my side. Because both Virtual Box and the lspci said there was 256MB I thought this was all the RAM that could be allocated. But the Virtual Box issue is something that isn't graphics card specific. So thanks for clearing it out! –  tversteeg Nov 7 '12 at 11:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.