Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Cyborg Rat 7 mouse with a thumb roller, which is great. I use it in Chrome to switch quickly between tabs right and left. I've got the left/right roll to be Ctrl+Tab and Shift+Ctrl+Tab.

I'd like to have multiple Terminal tabs open in OS X and switch between them the same way.

When I try to assign the Ctrl+Tab and Shift+Ctrl+Tab (with this article) keyboard shortcuts in the OS X Keyboard preferences, it won't let me because pressing Shift+Tab changes to the previous field in the dialog. Is there a way around this?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I could successfully configure CtrlTab and ShiftCtrlTab to switch between tabs in Terminal.

This is what I did (on OS X 10.8.2):

  1. Open System Preferences>Keyboard.
  2. Select tab Keyboard Shortcuts.
  3. Select Application Shortcuts from the list in the left hand side.
  4. Press + button.
  5. Select application "Terminal" (Terminal wasn't listed, so I had to press Other..., navigate to Applications>Utilities and select it).
  6. Type Select Next Tab as menu title (the menu title must exactly match the menu title that will have the shortcut replaced).
  7. As shortcut press CtrlTab.
  8. Press Add.
  9. Similarly, add menu title Select Previous Tab with shortcut press ShiftCtrlTab.

Note: If the menu title contains accents make sure you use the correct accent character. For example, in French Select Next Tab is called Sélectionner l’onglet suivant, and you must type instead of '.

The configuration in System Preferences looks like this:

enter image description here

The Window menu in Terminal looks like this (and works as expected):

enter image description here

share|improve this answer
    
Awesome, that totally did it. Looks like that article that I linked is wrong. –  jcollum Nov 19 '12 at 15:29
    
I had a quick look to the video in the article you linked and it describes the same procedure as above, I wonder what went wrong... Anyway, great to hear it also worked for you. –  jaume Nov 19 '12 at 16:18
add comment

Control+Tab is a reserved shortcut, according to Apple's Human Interface Guidelines.

Looking into it a bit further, it appears that you may have 'full keyboard access mode' enabled, as part of OS X's Accessibility features.

OS X provides the option of full keyboard access mode, in which users can navigate through windows, dialogs, menus, toolbars, and the Dock using the keyboard alone, without a mouse or other pointing device.

Users can turn on full keyboard access in the Keyboard Shortcuts pane of Keyboard & Mouse preferences. Control-F1 is a reserved keyboard shortcut for turning full keyboard access on or off. Control-F7 toggles between keyboard access for all controls in windows and dialogs and the default state, in which only text fields and scrolling lists are accessed with the keyboard. Don’t use these combinations for any other purpose.

It looks like you may be able to re-define the accessibility shortcut, and then define your custom shortcut for your mouse. Or, you might try turning off the accessibility features (if you have them enabled), and see if the shortcut becomes available.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.