Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use pylint on .py files for :make in my .vimrc, although any program, pylint or otherwise, applies to this problem.

set makeprg=pylint\ --reports=n\ --output-format=parseable\ %

When I run :make, I inevitably get the annoying Press ENTER or type command to continue prompt. I know this can be disabled with :silent, but I can't prepend it to the makeprg variable like this, because it throws an error:

set makeprg=:silent "pylint\ --reports=n\ --output-format=parseable\ %"

If I try to have my own "Silent make command,"

command Smake silent make

The screen goes black after calling it.

How would I do it?

share|improve this question
    
Why not :silent make? – romainl Nov 7 '12 at 15:17

You can use :redraw CtrlL (or :redraw! to clear the screen first).

:redraw

See that similar topic, and the Vim doc.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .