Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Solaris (open indiana) system which is getting poor disk write performance. In order to enable ZIL in this version of zfs I need to add a line to /etc/system. This will not take affect until I've unmounted and remounted the zpool. The trick is that this zpool is shared via nfs to about 200 other servers to host users' home directories. I can guarantee that no users will be accessing the disks during this period of maintenance but I would like to avoid having to issue an unmount for 200 systems in order to unmount the disk on the Solaris box.

My question is, with sharenfs, is it necessary to have all systems disconnected before unmounting the filesystem on the host? If it's possible, how do you go about it? I've tried unmounting already, the normal way, and it reports the disk is busy. There is no lsof in Solaris and pfiles (I think that's what it was) does not show anything obviously using the mounts.

::EDIT:: Additional Information

The line I was going to add to /etc/system is the opposite of the line I currently see set zfs:zil_disable=1

share|improve this question
What would you add to /etc/system? It wouldn't have any effect until you reboot the whole box, anyway. Please provide more details; perhaps we can help you better. – pino42 Nov 7 '12 at 17:04
I've added the line I was going to edit to my original question – Ted W. Nov 12 '12 at 14:58
Then I can confirm my answer. Go ahead, you do not have to reboot nor unmount your filesystems. – pino42 Nov 12 '12 at 23:22

I'll try to answer without the details. ;)

You don't have to unmount the filesystem to enable the ZIL. It is a system tunable that can be modified at runtime. Do edit /etc/system as you plan to, since that will be needed after you reboot, but in the meantime issue the command:

echo zil_disable/W0t0 | mdb -kw

and the ZIL will be enabled.

You can find more details and examples here.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .