Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to remove "Homegroup" from the left side of my Windows Explorer in Windows 7/8.

enter image description here

share|improve this question

3 Answers 3

up vote 12 down vote accepted

To remove Homegroup (and stop Homegroup networking functionality):

Go to Control Panel -> Network and Sharing Center -> HomeGroup, and click on "Leave the homegroup" link and confirm to unjoin from any existing home group. Note: If the home group are shared and hosted from the PC, all HomeGroup connections will be disconnected.

In the future, if you want to use Homegroup networking you can create a homegroup using this same dialog.

Go to Control Panel -> System and Security -> Administrative Tools, and double click on Services. Alternatively, type services.msc in Start Search.

For each of the following two services:

  • HomeGroup Listener
  • HomeGroup Provider

Do the following:

Stop the service, and then double click on the service to open Properties dialog, and set its Startup type to "Disabled". Click OK when done. In order to reinstate Homegroup functionality in the future, you will want to set the Startup type back to Manual.

The HomeGroup icon and group will no longer be shown in the navigation pane of Windows Explorer in Windows 7. Note that this does not interrupt "traditional" windows networking functionality (e.g., Map Network Drive).

more useful links:

share|improve this answer

First, leave any homegroup network as follows:

  • start > control panel > network and internet > home group. Then click on Leave homegroup link. Click finish when done.
  • Now, to get rid of the icon from the explorer
  • start > control panel > system and security > administrative tools > services
  • now you need to deal with two services.
    Homegroup Listener
    Homegroup Provider
    For both, stop the service. Double click to open its PROPERTIES. Set its STARTUP TYPE to disabled.
    Done

    share|improve this answer

    To get rid of the Homegroup Icon in the Explorer:

    The Peer Networking services and Homegroup Services MUST be started.

    Otherwise, you will get an error message when attempting to "Leave the Homegroup".

    share|improve this answer
    1  
    As written, your answer provides very little useful information. Can you expand it on a bit? –  DragonLord Nov 30 at 20:04

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.