Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem unable to initialize hardware-accelerated OpenGL on the GPU side of the Intel Ivy Bridge GPU (it's on a Core i7-3700K chipset, with the HD4000 graphics core).

This is a new problem on Windows 8. I distinctly recall having access to GPU-accelerated OpenCL on Windows 7. In fact, it came in the built-in Intel processor graphics drivers.

The symptom that I observe: every OpenCL program I run (whether the program is 32-bit or 64-bit) shows that the Intel OpenCL platform can only execute on the CPU. When measuring the performance, it is definitely slow enough to be running on the CPU. From what I have seen, the GPU side is about 3-4 times faster; I'd like to have access to that on Windows 8.

Am I missing a separate driver download? I've already tried the Intel OpenCL SDK, both version 2012, and 2013 Beta. Still I can only use OpenCL on the CPU, which is very slow compared to what a GPU is capable of.

share|improve this question
I suggest reading this article. – harrymc Nov 11 '12 at 14:57
up vote 1 down vote accepted

As far as I can tell, its caused by the installation of Catalyst drivers (e.g. atiumdag via Windows Update).

This deploys a service 'AMD External Events Utility' set to start automatically.

When the PC next reboots it does something which causes cause the IGP OpenGL driver to fail to load.

You should be able to prove this / make a working system as follows:

  • Install Windows 8 with a display connected only to IGP
  • Optional: When prompted to reboot for updates, disable service 'AMD External Events Utility'
  • Install AMD APP SDK 2.8
  • Run clinfo.exe

Although I just disabled automatic updates, installed Catalyst then immediately disabled the service.

Unfortunately while updating to the latest Intel drivers seems to be ok, updating Catalyst to later drivers triggers the the service again.


Have posted these details on the AMD forum, hopefully can find out a bit more about the cause, and how to resolve without a reinstall. I've managed to get my main system to go from not-working back to working but I can't rememeber exactly what I did.

Now that I've got one system running Catalyst 13.1 and the Intel beta driver the performance seems to be actually worth bothing with; LuxMark Sala scores were:

  • ~2050 on the 7970 GPU
  • ~2350 running 7970 and Intel HD4000 together
share|improve this answer
This isn't really an "answer" so much as sharing your own experience, but I wanted to remark that this is valuable, so thank you for providing your feedback. Unfortunately I can't do a clean install every time I need OpenCL. Huge disappointment so far in the drivers. – allquixotic Feb 28 '13 at 23:14
Thanks, have edited with the result of more digging. – Peter Wishart Mar 1 '13 at 2:33

This is going to sound lame but you need to check your driver version. I am not sure that the version provided by Windows Update is the latest. Also, this kind of thing happens when there is a bug in the application (such as not properly querying OpenCL Support).

Intel pushed some graphics drivers with the string Verify that this is what you are running. You need to post your driver string before we can debug this. See screenshot where this info can be found.

Intel Graphics HD veresion string

If you have the source, you also might be targeting the wrong device. Notice how in the screen shot below your build chooses which device to target and run on. If this is wrong you will be running on the emulator. enter image description here

share|improve this answer
I have tried several (5 to 6) GUI applications which allow you to select both the platform (the OpenCL implementation) and the device. The only items I see in the list are CPU for Intel SDK, and GPU for AMD APP SDK (I also have a discrete Radeon card). I have the latest drivers, released on October 23, 2012. – allquixotic Nov 7 '12 at 14:17
@allquixotic I wonder if this is by design due to computer having two graphics cards. The performance difference you experience is similar to the worst case when changing CUDA versions. OpenCL is optimized in a way that small changes will result in +/- 2x performance differences. – Mikhail Nov 7 '12 at 14:19
Maybe, but the Intel OpenCL platform implementation specifically says CPU with no option for selecting a GPU device, whereas before it would report using the HD4000 graphics and say "GPU". – allquixotic Nov 7 '12 at 14:54
There should be a way to use the OpenCL stack of both my Intel GPU and a discrete Radeon at the same time. They use separate ICD implementations (Intel SDK and AMD APP SDK) and it's already possible to use the OpenCL CPU simultaneously with the GPU. – allquixotic Nov 7 '12 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .