Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In man page of finger it's showing

Finger may be used to look up users on a remote machine. The format is to specify a user as “user@host”, or “@host”

so I tried

[max@localhost ~]$ finger max1@x.x.x.x

Then it's showing this error

finger: cannot create socket / connect host

what is the reason?

I need output by using finger command only

I am using Centos 6


update

[root@localhost ~]# yum install finger-server
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base: mirrors.hns.net.in
 * epel: ftp.cuhk.edu.hk
 * extras: mirrors.hns.net.in
 * updates: mirrors.hns.net.in
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package finger-server.i686 0:0.17-39.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch          Version               Repository     Size
================================================================================
Installing:
 finger-server          i686          0.17-39.el6           base           15 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total download size: 15 k
Installed size: 11 k
Is this ok [y/N]: y
Downloading Packages:
finger-server-0.17-39.el6.i686.rpm                       |  15 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : finger-server-0.17-39.el6.i686                               1/1 
  Verifying  : finger-server-0.17-39.el6.i686                               1/1 

Installed:
  finger-server.i686 0:0.17-39.el6                                              

Complete!

There is no daemon called fingerd

[root@localhost ~]# chkconfig --list | grep -i fingerd

only finger service its showing and it's on

[root@localhost ~]# chkconfig --list | grep -i finger
    finger:         on

but still same problem...

share|improve this question

1 Answer 1

This will only work if the remote host is running a finger daemon that will respond to the query, but it's been many years now since it was common for hosts to run one of those.

share|improve this answer
    
what is the daemon name? –  max Nov 7 '12 at 9:03
    
"fingerd", following the convention of daemons ending in 'd' –  pjc50 Nov 7 '12 at 9:48
    
The package you want is finger-server but if the machine is internet accessible you probably want to think about restricting who can access it in some way. –  TomH Nov 7 '12 at 10:21
    
Most SAs disable the finger service for security reasons. –  fpmurphy1 Nov 7 '12 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.