Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

"Update server not available (error: 12)"

This is what I get when I check for updates in Chrome - About Google Chrome.

I tried the official solution which did not work:

I tried everything here which did not work:!topic/chrome/t9iK_JcJsuA

I hoped it would be solved by manually updating from 21.x to 22.x but no.

OS X 10.8.2

share|improve this question

I know this is an old question, but I have run into this issue over and over again while running various versions of Chrome on OS X 10.9. I too tried the solutions at and!topic/chrome/t9iK_JcJsuA but never had any luck. I would always resort to downloading and installing the latest from Google. Today, ran into the issue again and decided that there HAD to be a solution.

After the most recent failed update attempt, I turned to the Console. A quick search for "chrome" revealed the following GoogleSoftwareUpdateDaemon error:

2/21/14 5:18:33.570 PM GoogleSoftwareUpdateDaemon[1784]: -[KSInstallAction performAction]
    KSInstallAction install script failure. (productIDs:
    [ - '/tmp/KSInstallAction.6E6RqXqHyw/m/.keystone_install']
    (" can't patch nonexistent or irregular file /Applications/Google Chrome Framework.framework/Resources/am.lproj/locale.pak\n.keystone_install: dirpatcher of versioned directory failed, status 12\n"

A closer inspection of the "nonexistent or irregular file" in the error revealed that it had to do with a localized version of Chrome. While conducting a deeper Google search, I found a similar error message with this comment: "Do you have an application installed that removes localizations from application packages?" It was then that it dawned on me that I had been using CleanMyMac to, among other things, remove "unneeded" localization files from my machine! And, sure enough, it was removing all but the required en.lproj resources from Google Chrome, including the am.lproj folder that the updater was complaining about in the error.

My solution: Download and install the latest version of Google Chrome and either turn off any localization removal settings in cleaner apps you may use or, like I did, add an exception to ignore Chrome during cleaning.

Good luck!

share|improve this answer
Overambitious cleaning by CleanMyMac2 ended up being my problem as well. Thanks! – user72923 Feb 27 '14 at 23:10
i seem to have the same problem, thanks a lot. – Inan Berbatov Feb 28 '14 at 10:13

There is extensive discussion about this issue here:!topic/chrome/t9iK_JcJsuA

I followed many of these steps, including reinstalling the Google Updater but the issue remained. Finally, based on one of these recommendations, I changed my Chrome settings to "allow 3rd party cookies" to be set. This resolved the issue.

Google Chrome > Settings > Show Advanced Settings > Content Settings Un-check the setting "Block 3rd party cookies and site data", at least long enough to go to "About Google Chrome" and check for updates.

share|improve this answer
I have this unchecked by default but my Chrome still refuses to update. – Ngoc Pham Sep 20 '13 at 1:20

If you are using an application that removes localizations from apps (like CleanMyMac as I was using), this may be the answer.

According to this thread, it's because of the localizations stripping.

Nearly all of the update logs I get are due to The steps to fix are:

  • Disable the application that is installed that strips application packages
  • Manually re-install Chrome
  • The next update should work; if not, file a bug ( at )
share|improve this answer
This seems like a plausible reason. – halfcube Nov 10 '15 at 14:31

I have ~40 OSX 10.7.5 clients that had this issue from time to time when going from 20.x to 23.x and 24.x

In terminal:

defaults write checkInterval 1

After re-launching Chrome I am then presented with a button, Set Up Automatic Updates for All Users. Clicking on that and authenticating shows the update process starting but then fails again with another error 12, except it actually is updating. Re-launching after about 5-15 seconds then shows the browser as up to date. I have no idea why the second error 12 reappears but I have seen it on every one of those clients I've updated recently even though the browser actually is updating. Those that remained at version 20.x were only able to update after changing that value in terminal.

If this still does not work, check to make sure you are trying to update the browser with the same account that initially installed Chrome. I have seen cases where the only solution was to completely remove Chrome (Firefox as well) from the system and reinstall.

share|improve this answer
Thanks, I'll test it with their next update. – Pieter Jan 13 '13 at 10:16

Google has a help page on how to fix this here. The first option didn't work for me but the second did. Copied on 9/25/13


  1. In the Finder menu at the top of your window, select Go > Go to Folder > ~/Library/Caches.
  2. Delete the following file (if present):
  3. Now delete this file (if present):
  4. Try to update Google Chrome again.


  1. Quit Google Chrome and any other Google applications.
  2. In the Applications menu at the top of your window, select Utilities.
  3. Double-click the Terminal program.
  4. Run the following command. Be careful to enter the command exactly as written:
  5. ~/Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/ --uninstall
  6. Now run this following command. Again, carefully enter the command exactly as written:
  7. sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/ --uninstall
  8. Download the Google Software Update installer.
  9. Double-click the downloaded "googlesoftwareupdate-version#.dmg" file to open the disk image.
  10. Inside the disk image, double-click the "GoogleSoftwareUpdate.pkg" installer.
  11. Follow the onscreen prompts to reinstall Google Software Update.
  12. Eject the "GoogleSoftwareUpdate" disk image.
  13. Restart Google Chrome.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .