Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop performs very poorly for 2d graphics. For example, Docky's zoom effect and compiz effects are very choppy. In Jaunty, I was able to fix this by adding the following line under the "Device" section in my xorg.conf:

Option "MigrationHeuristic" "greedy"

In Karmic, there is no xorg.conf by default, so I copied my old one (from Jaunty). However, everything is still slow. Here is my xorg.conf:

Section "Device"
    Identifier	"Configured Video Device"
    Option	"MigrationHeuristic" "greedy"
EndSection

Section "Monitor"
    Identifier	"Configured Monitor"
EndSection

Section "Screen"
    Identifier	"Default Screen"
    Monitor		"Configured Monitor"
    Device		"Configured Video Device"
EndSection

From googling about, it sounds like "MigrationHeuristic" is only an option for the "EXA" mode, while Karmic has switched the intel driver to "UXA". So I tried adding this line under the "Device" section:

Option "AccelMethod" "exa"

But this didn't help.

share|improve this question
add comment

2 Answers

The answer given above is completely wrong. There is still a way to apply the Option "MigrationHeuristic" "greedy". This is how you do it.

sudo service gdm stop

This stops Xserver and takes you to the Linux Prompt. Login with your credentials. From there do this.

sudo Xorg -configure

This creates a new file named xorg.conf.new in your home directory. After that type

sudo vim xorg.conf.new

Now add the Option MigrationHeuristic "greedy" line to your xorg.conf.new file under the "Device" section. Save and exit. Now type

startx

This starts up Xserver again. This time everything should appear snappy.

share|improve this answer
add comment
up vote 0 down vote accepted

This is not possible in Ubuntu Karmic, because of the switch from "EXA" mode to "UXA" mode. The problem with Docky specifically, however, can be fixed by launching it as docky --netbook or docky -n (you must be running Docky2, not Docky1 (the Docky in Gnome Do)). It is a bug in the Intel drivers (for some reason they perform very poorly rendering things with width or height between 1009 and 1024), and Docky2 provides a workaround.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.