Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I built a PC, but connected the SSD to a SATA 2 port (the blue ones looked more impressive/faster than the grey ;) ). I installed windows 8, everything working fine.

I then noticed the SSD was connected to the SATA 2 instead of SATA 3, so I reconnected the SSD to the SATA 3 port.

I rebooted the PC. The BIOS splashscreen displays, then the new windows icon, then before the waiting loading animation is displayed the PC turns off.

If I reconnect the SSD back to the SATA 2 port the PC boots without an issue. When ever I connect to the SATA 3 port the same issue occurs.

I tried loading the Windows 8 DVD (oem) but before it loads (DVD has boot priority) the PC turns off at the same point.

I've installed latest SATA drivers from ASUS website, and still same issue.

A bit more testing reveals that it works only on SATA2 ports 3 and 4, but not SATA2 ports 5 and 6 or SATA3 ports 1 and 2.

What could be going wrong.

share|improve this question

You should check to see if (somehow) your SATA3 ports default to booting in AHCI or RAID rather than the (usual) default IDE on the SATA2 ports. Windows will bomb out once it loads the driver it thinks is correct for the SATA ports, and when it realizes it's not the correct driver, it dies.

share|improve this answer

Updated to the latest BIOS (1616) and the other SATA ports magically worked. By the way, this motherboard is an ASUS P8Z77-M PRO.

share|improve this answer

Strongly suspect this is an issue with the M$'s driver for your SATA3 port. I have multiple similar problems with Windows 7 installations. Try getting a the most recent driver for the SATA3 port driver from your motherboard or the chipset manufacturer (Marvell, NEC or similar) and load it via the F8/load custom driver option (assuming that exists in Windows 8 world).

share|improve this answer
loading latest drivers did not work. – user9802 Nov 7 '12 at 12:24
This likely isn't an MS driver issue if it's shutting off before the DVD even loads (#8 above). That would seem to me it's more likely a problem with the BIOS or with the SATA3 port itself. – BBlake Nov 7 '12 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .