Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Windows 8 Pro on a blank new SSD, the system is on c:\. I do not think this problem was existent when I started using Windows 8 but I think it started to happen after I've symlinked (mklink /D) a folder from another drive, a SATA drive, to c:\xampp\htdocs.

When I right click a file or folder inside the symlinked folder it always takes at least ~5-10 seconds until the context menu comes up. This also happens sometimes, but not all the time for files and folder outside of the symlinked folder.

Also when I delete folders the delete folder dialog seems to get locked and does not continue. When I delete a folder using rmdir from the command line it works fine and pretty fast.

It appears to me like the file explorer in Windows 8 is pretty bad compared to any other Windows I've used before? Any idea how to get these problems solved? I've already removed a lot of context menu entries; the only ones left are the tortoise git context menus but I'm sure that's not the problem.

share|improve this question
add comment

2 Answers

I actually think it is tortoise git that's slowing it down. I noticed the slowdown immediately after installing it.

share|improve this answer
add comment
up vote -1 down vote accepted

I just found this, its for Win 7 x64 which I've used for years before without these problems. http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/bdfc446f-7f5f-448e-8022-5ee9c0e89126

In my case the issue was the windows search index service. It's working fine now that I've disabled the search indexing service. I consider this a poor workaround and hope there is a real fix for the issue soon from MS.

The smylinked folder and the target where never part of the indexing, I've checked this before I disabled it. So I doubt that the symlink is related to the problem.

But well, so far I cant say it works slower without the indexing service but I guess it's just because I don't have software that relies on it.

share|improve this answer
    
disabling the service for issues with your symlinked folder is like burning your house down for spilled milk in the kitchen. You can manage the indexing locations (explicit add or excludes) by going Win+W and searching for 'Indexing Options'. –  edusysadmin Nov 9 '12 at 17:02
    
It is not because the smylinked folder and the target where never part of the indexing, I've checked this before I disabled it. Thanks for downvoting... –  burzum Nov 10 '12 at 14:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.