Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all I'm danish so my English is probably flawed. At my company I've had some complaints that after having installed Chrome certain pages on our intranet website was off limits.

So I took two completely similiar machines, Lenovo T520, Windows Vista 32bit same Internet Explorer version (9) Same java version (7.9) and same windows updates..

I went to our intranet website and clicked a link thats suppose to open a popup with some text and it worked on both of them. Then I took one machine, installed Google Chrome, uninstalled it again, put Internet Explorer back to standard browser, and then tried the same link. and Now I get a JavaScript error. and it won't open the link.

this error is in danish and I translated it to English

SCRIPT5007: The value of this document cannot be collected The object is null or not defined. XXX.js, line 32 number 7

These 2 machines, are now completely identical, except one of them used to have Chrome installed. but only one of them works. My limited experience tells me its a changed safety setting somehow. I had this confirmed cause I went to internet settings in Explorer.. and turned off what in danish is called 'beskyttet tilstand' and I guess its translation is 'safe mode'

And now it works on the machine that used to have Chrome, but! On the other machine it works even with 'safe mode activated'

I read a bit about what Chrome might have done to the registry that should prevent links from opening and changed CurrentUser\software\classes\html from 'ChromeHTML' to 'htmlfile' and that fix does indeed make sure the computer is now able to open links in internet explorer once again But it doesn't fix this javascript error and the fact I can't open this hyperlink. So to sum up.

The machine that had Chrome installed is only now able to enter this hyperlink if the safe mode is off while the machine that never had Chrome installed is able to access the same link with safe mode activated. and believe me the machines are otherwise identical, and never been used.

I know this is a rather big 'rant' so if my information is insufficient please let me know.

share|improve this question
    
Please can you show the Danish version of the error message, or at least explain whether you translated the word "document" or not? Also please show line 32 (and a few lines before it) of XXX.js? It is likely that the problem you have here is that the JS in the page you are viewing sniffs for IE and does something non-standard that IE9 no longer does, unless it is forced into quirks/compatibility mode. Is it possible for you to modify the website you are viewing? Chances are adding <meta http-equiv="X-UA-Compatible" content="IE=8;FF=3;OtherUA=4" /> at the top of the HTML would fix it. –  DaveRandom Nov 7 '12 at 14:18
    
I don't administrate the website, but if changes have to be changed to the site I can make it happen. It doesn't make much sense to me though as the site hasn't changed.. and previous to the chrome installation it worked fine. Error: I did indeed write the wrong thing. it says "the value of 'document' not 'this document' ...... This is the line it refers to: MyWin.document.write('<html><head><title>infomeddelelse</title>') And just to make it clear. if I remove "safe mode" from internet settings, it works again but on the machine that never had Chrome.. it works with safe mode activated. –  Allan Pedersen Nov 7 '12 at 14:28
    
It seems that some (probably) registry setting set by Chrome and not reset afterwards is preventing IE9 from loading the page in (probably) quirks mode, and it's hard to know where to go from here. Can you show the Danish version of "safe mode"? IE has both "safe mode" and "quirks mode" in English, and while they translate in a similar way in this context, they do very different things. If it's quirks mode I would guess that the way that MyWin has been populated in a non-standard way, like using parent in the top level window object or a popup. If "safe mode", the problem is a plugin. –  DaveRandom Nov 7 '12 at 15:31

6 Answers 6

Use the Reset Internet Explorer last-resort button. You can use the Internet properties dialog (Tools -> Internet Options) to get there. Then go to the last tab, and at the bottom is the button. This should fix it. It probably won't interfere with the working of Chrome. Also send a bug report to Chrome bug reports, optionally.

share|improve this answer

Try using registry-tracking software like RegShot. Install it on a clean, working environment (IE-only, as you said above). Then install Chrome on the machine and use it to see what changes it made.

Pretty sure it should solve your problem :)

share|improve this answer

This Stackoverflow question has a few answers that may solve your problem.

Assuming you are using Internet Explorer 9 or Internet Explorer 10, a rather common problem is due to the different way it parses object/embed element. This is common for webpages with flash content. The answer from the link above suggest adding an HTML element to the webpage.

Assuming you do not have the ability to do so, you can change the compatibility mode within Internet Explorer. Click on Tools -> Compatibility View Settings and add in your website.

Google Chrome does not make any changes to the installation of Internet Explorer.

share|improve this answer

This makes no sense but it worked for someone who couldn't load any pages:

disable adobe shockwave object add-on.
a. Open Internet Explorer.
b. Click on Tools.
c. Click on Manage add-ons.
d. Search for the shockwave object add-on.
e. Click on Disable.
f. Click on Close.

Caused by an august update to IE.

Safe Mode may turn off addons? So turning them off would do the same as the above fix...

Clear cookies and cache...

I would actually uninstall all instances of IE and do a clean reinstall of it. Make sure javascript is enabled. Update Java.

Or I found this: With the site you want open, go to Internet Options-> Security and click on Trusted sites and add it.

1 Press ALT + T + B. This will open up the Compatibility View Settings dialog box.

2 In the dialog box, type the name of website that is creating problems. You need
not type http:// or www with the URL. For example, if you are adding Facebook to 
Compatibility List, just type facebook.com.

3. Click on Add. The website URL will appear in the larger box just below where you
typed the URL.

4. Click on Close to close the Compatibility View Settings dialog box.

Best solution - use firefox! (although to use the Net10 website I had to use chrome... firefox and IE wouldn't work, so firefox won't work for every site, although that's true of all browsers now.)

I had a problem where IE wouldn't load any pages, and the solution was to delete some files... unfortunately I can't remember what files they were except they were in a folder SOMEWHERE that was named with an older version of IE, and I can't find the page I found that info on either! I wish I could because my problem happened after I installed chrome but I never made a connection (and supposedly the problem is caused by an update to IE, but I don't update).... I'll keep looking for this one...

The error I was getting was "the requested lookup key was not found in any active activation context "... still looking for the files to delete though... my problem was caused by installing an older version of IE over a newer one (but I swear I didn't...) Information here http://www.mitchellenright.com/2011/11/01/requested-lookup-key-was-not-found/ but I don't like using microsoft tools to fix things so still looking for instructions I followed

share|improve this answer

I believe this due in part to the fact that Chrome only uses 32-bit java where as internet explorer can use 64-bit. Even though you can't seem to support 64-bit this might be causes the error.

share|improve this answer

I suggest to reset Advanced Settings of Internet Explorer.

Tools > Internet Options > Advanced > Restore advanced settings

Also make sure that you are using Internet Explorer 32 bit version, as most of the plugins are not supported in 64 bit Internet Explorer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.