Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i am on a new Gentoo installation and when trying to emerge kde4.9.3 through kde4 layman overlay i get the following error for kdepimlibs-4.9.3

-- Found Sasl2: /usr/lib64/libsasl2.so
-- Looking for include file sys/select.h -- Looking for include file sys/select.h - found -- Looking for include file sys/socket.h -- Looking for include file sys/socket.h - found -- Looking for include file sys/types.h -- Looking for include file sys/types.h - found -- Found SharedMimeInfo: /usr/bin/update-mime-database (found suitable version "1.0", required is "0.30") -- Found Libical version 0.48 -- Found LIBICAL: /usr/lib64/libical.so;/usr/lib64/libicalss.so
CMake Error at /usr/share/cmake/Modules/CMakeExportBuildSettings.cmake:17 (MESSAGE): The functionality of this module has been dropped as of CMake 2.8. It was deemed harmful (confusing users by changing their compiler). Please remove calls to the CMAKE_EXPORT_BUILD_SETTINGS macro and stop including this module. If this project generates any files for use by external projects, remove any use of the CMakeImportBuildSettings module from them. Call Stack (most recent call first): gpgme++/CMakeLists.txt:121 (include)

-- Configuring incomplete, errors occurred! * ERROR: kde-base/kdepimlibs-4.9.3 failed (configure phase): * cmake failed * * Call stack: * ebuild.sh, line 85: Called src_configure * environment, line 3899: Called kde4-base_src_configure * environment, line 2941: Called cmake-utils_src_configure * environment, line 1064: Called _execute_optionaly 'src_configure' * environment, line 486: Called enable_cmake-utils_src_configure * environment, line 1384: Called die * The specific snippet of code: * "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed"; * * If you need support, post the output of emerge --info '=kde-base/kdepimlibs-4.9.3', * the complete build log and the output of emerge -pqv '=kde-base/kdepimlibs-4.9.3'. * This ebuild used the following eclasses from overlays: * /var/lib/layman/kde/eclass/kde4-base.eclass * /var/lib/layman/kde/eclass/kde4-functions.eclass * /var/lib/layman/kde/eclass/cmake-utils.eclass * This ebuild is from an overlay named 'kde': '/var/lib/layman/kde/' * The complete build log is located at '/var/tmp/portage/kde-base/kdepimlibs-4.9.3/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdepimlibs-4.9.3/temp/environment'. * Working directory: '/var/tmp/portage/kde-base/kdepimlibs-4.9.3/work/kdepimlibs-4.9.3_build' * S: '/var/tmp/portage/kde-base/kdepimlibs-4.9.3/work/kdepimlibs-4.9.3

Does any one knows how to solve it? Thx in advanced

share|improve this question
    
It looks like there is a newer version of cmake in the kde overlay. Use that. –  Ярослав Рахматуллин Nov 7 '12 at 18:56
add comment

1 Answer

The problem exists with new versions of cmake as the cmake-file requests functions removed in newer versions. So you need to use an older version than 2.8 (as the error message requests)

i.e. add

>dev-util/cmake-2.8

to your /etc/portage/package.mask to accomplish that and retry.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.