Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to have perfectly working internet connection sharing on my Windows 7 (with all updates installed).

Later then, I have bought Windows 8 (Open a wider world) and the downloaded assistant told me that all gonna be alright in the progress of upgrading. Yeah, tell me about it.

Immediately after simple three hours it was finally delivered and I have found out my wife cannot reach the web. It was kind of surprise since everything else kept working. My games, my studio, my desktop, every little option was looking the way it was before that thing was installed.

Except for one thing. The ICS. All the settings are completely okay. They are the same as they were! I have double-checked, as well as re-set them all on both computers (mine and wife's). And still no internet access from her desktop.

What can be the reasons of it and what are their solutions?

Update:

My connections:

Can you elaborate on how your network setup is? Is it wired? Wireless?

Wired, simple twisted pair.

Why don't both you and your wife connect directly? Why do you need ICS?

Because that (above) WAN connection working only on one computer, not on both. If I try to create another session, the old one is aborted.

share|improve this question
1  
Can you elaborate on how your network setup is? Is it wired? Wireless? why don't both you and your wife connect directly? Why do you need ICS? –  Erik Funkenbusch Nov 9 '12 at 18:04
add comment

1 Answer

up vote 1 down vote accepted
+100

The thread Internet Connection Sharing ( ICS ) not working in Windows 8 CP recommends to set the ICS service start-mode to "auto(delayed)".

Run services.msc, look for the "Internet Connection Sharing (ICS)" service and set its Startup type to "auto(delayed)".

To have it take effect, restart the PC or stop and restart the service.

The service will loaded a few minutes after you boot Windows.

share|improve this answer
    
And what will it do for me? The service is running anyway and the sharing is not working. –  AgentFire Nov 10 '12 at 6:23
    
If the above doesn't work (please try it), my conclusion will be that the upgrade somehow failed. You could try sfc /scannow. Otherwise, I would suggest a clean install of Windows 8. And if all fails, then I hope you have taken a disk backup of Windows 7 before the upgrade. –  harrymc Nov 10 '12 at 6:35
    
It worked. Actually. –  AgentFire Nov 10 '12 at 7:50
    
The only explanation is that there is a dependency missing for the ICS service. Windows services that are dependent on others will start after them, or they will fail if started too soon. By postponing the start of the ICS service, you have ensured that whatever undeclared service that it's dependent upon will have already been started. –  harrymc Nov 11 '12 at 11:48
    
It didn't worked as you say. Delayed start still failed to shared access. But the thing worked for me is a simple service restart. Weird, you know. –  AgentFire Nov 11 '12 at 16:57
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.