Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

keithp seems to be the only one on the interwebs to have written anything about the subject and he worked with 3.5_rc. I don't want to go above 3.4 at the moment for various stability reasons and am trying to see whether I can get this to work. Xorg 1.13 recognizes the display on connection, "udl" module is loaded, xorg-video-modesetting driver also loads, display lights up. So everything seems to be good.

I emerged xrandr-9999 (not many changes on top of 1.3.5):

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 69 cap: 0x0 crtcs: 2 outputs: 4 associated providers: 0 name:Intel
Provider 1: id: 338 cap: 0x0 crtcs: 1 outputs: 1 associated providers: 0 name:modesetting

But I can't get any further, just like this guy:

$ xrandr --setprovideroutputsource 338 69
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  35 ()
  Value in failed request:  0x152
  Serial number of failed request:  11
  Current serial number in output stream:  12

$ xrandr --setprovideroutputsource 1 0
X Error of failed request:  148
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  35 ()
  Serial number of failed request:  11
  Current serial number in output stream:  12

Any thoughts?

share|improve this question
    
I am now using DisplayLink hotplugging on 3.10 and it works as advertised, so this question is mostly irrelevant. –  lkraav Aug 4 '13 at 22:09
add comment

3 Answers

up vote 2 down vote accepted

Please read this article http://www.phoronix.com/scan.php?page=news_item&px=MTEzNjc and follow links cited there. I've made several test of various distros and I can confirm, that what we need is the full support for PRIME in kernel, Xorg and randr. Then it shall work. Please investigate what PRIME is...

Personally, I'm expecting that full support to Displaylink devices could be available in the year 2013 the earliest. On old kernels probably you can make it working, but only via manual setting config files as described in this article http://mulchman.org/blog/?p=21

Without PRIME you can have either Displaylink working or Intel \ nVidia \ ATI but rather never both of them under one instance of Xorg. I tried it and gave up.

Marek

share|improve this answer
    
Thanks. Specific info about PRIME seems to be difficult to come across, so I'll paste this paragraph from h-online.com: "PRIME", a basic drm dma-buf interface layer for exchanging information about graphics cores without much overhead. This is one of several components which will allow Linux distributions to switch graphics cores on and off without the user having to restart the X server or make other interventions. It's interesting, not just for DisplayLink monitors, but also for notebooks, where systems like NVIDIA's Optimus technology can activate a more powerful graphics chip at run time. –  lkraav Nov 15 '12 at 21:14
add comment

If you are really convinced to use your existing configuration make use of this tutorial http://nameq.wordpress.com/2011/09/21/displaylink-dl-165-running-on-linux-fedora/ I didn't tried this method. IMO it should be working, though still on 2 instances of Xorg.

Marek

share|improve this answer
    
I'm already doing the dual Xorg setup and it's a bit annoying to quit/start apps to move them over to the other X instance. –  lkraav Nov 15 '12 at 21:15
add comment

My test today was performed on xubuntu 12.10 (amd64) using some hints from this article: http://www.webupd8.org/2012/11/how-to-use-multiple-monitors-in-xubuntu.html?utm_medium=twitter&utm_source=twitterfeed

Alas, Displaylink's are not working in 1 instance of Xorg together with nouveau. Actually kernel modules are loaded, devices /dev/fb* created, though xrandr --listproviders doesn't list DL devices. Interesting fact: although udl / udlfb modules are loaded, in this distro DL screens were black (in standby), and not green as described in many tutorials published before. Something is still missing (I didn't try to compile x11 drivers, but also I couldn't find them in repository). I didn't investigate for reasons further simply because I'm waiting for new release of Fedora.

Fedora 18: Beta should be available by end of this month, final release in January 2013.

Fedora 17 is using already kernels 3.6.x and for me seems that Fedora 18 shall to be the first candidate to have support for PRIME and DL's (if it will consist of newest Xorg, randr and related). A good thing is to keep track on http://distrowatch.com/

Should you find something interesting, share it please.

Maybe you'll find it useful - how to obtain info about your existing state of a system - check out this thread http://askubuntu.com/questions/28033/how-to-check-the-information-of-current-installed-video-drivers

A handy utility is KInfoCenter - however it requires libraries for KDE (I don't know what window manager are you using?). You can get it from from most of repositories based on Debian (command: sudo apt-get install kinfocenter)

share|improve this answer
    
Based on my observation, udlfb == green screen, udl == black screen. I'm using i3 wm. Maybe worth noting is I've experienced some very unusual kernel panics when using udl (blacklisted udlfb) on 3.4.18+. Switching back to udlfb (blacklisted udl) seems to have set things back to normal. –  lkraav Nov 20 '12 at 18:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.