Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a big IPS monitor with 1920x1080 resolution, and some programs look blurry. Here's a screenshot to demonstrate: enter image description here

You can see on the left that the text in Firefox looks sharp, while the text in the Audible Downloads window to the right looks blurry. Other programs that are blurry include Google Chrome, Notepad++, and I"m sure there are more. Other programs like VLC and Office, look sharp. Paint.NET has sharp text but the icons are blurry.

I set the display to 150%, so I understand how this can make images (icons) look blurry, but what about fonts? Is there anything that can be done about them?

share|improve this question
1  
Looks to me like some per-app ClearType thing. Maybe some apps are trying to be too clever by half. You may also want to check your graphics driver's bundled software to see if there's anything related to this in there. –  Karan Nov 7 '12 at 21:57

5 Answers 5

up vote 6 down vote accepted

I had the same problem, and i fixed it by toggling "Use Windows XP scaling" on and off a couple of times.

Reboot, or log out/in between the changes.

You find the setting as a check-box in:

"Screen Resolution"/"Make text and other items larger or smaller"/"Custom sizing options"/"Use Windows XP scaling"

It was unchecked when i started, and is unchecked now. For some reason it had to be turned on and off again (LOL) to fix this.

share|improve this answer
    
That worked. Thanks a lot! –  EpsilonVector Nov 24 '12 at 21:20
    
My issue was blurry images / text in Foxit Reader. Overall solution worked for me as well. Though I only had the check the box once, not check and uncheck several times. Also, for me on Windows 7 Pro, the box is under "Control Panel" -> "Display" -> "Set custom text size (DPI)" -> "Use Windows XP style DPI scaling". –  Peter D Aug 4 at 18:56

Have you tried the ClearType tuner? It can really help with high res DFP monitors, especially on older OSes. I'm not sure what you are running, but here is a great place to start: https://www.microsoft.com/typography/ClearType/tuner/tune.aspx

share|improve this answer
    
How would that help when some apps are exhibiting this, not all? –  Karan Nov 7 '12 at 21:55
    
some apps use acceleration, and others don't. some use truetype fonts, and others don't. the OS doesn't control every aspect of an apps display unless the app lets it. –  Frank Thomas Nov 7 '12 at 22:05
    
True, I mentioned that above. But isn't the ClearType tuner a system-level and not per-app tool? Would it help improve the display of only an app like Audible, while leaving an app like FF alone since the latter already looks fine? –  Karan Nov 7 '12 at 22:12

For me, the solution was as follows:

  • R-click on COMPUTER.
  • L-click on PROPERTIES
  • L-click on Advanced System Settings
  • L-click on Advanced menu
  • L-click on SETTINGS in the PERFORMANCE box.

Then, on the visual effects tab:

Uncheck the "Enable Desktop composition"

share|improve this answer

Goto Screen Resolution>>Make Text and Other Items Larger or Smaller

Then Check "Let me choose one scaling level for all my displays"

That worked for me.

share|improve this answer

High DPI devices, such as 1920x1080 resolution displays require some sort of intervention from the operating system to prevent "ordinary" text from becoming painfully small.

The root cause of the problems is how this is done, and whether the way it does so accomodates legacy programs.


BEST SOLUTION:

For any application that has the problem, right click the executable > Properties > Compatibility tab > uncheck disable scaling for High DPI devices.

That should do it.

An excellent explanation for why is given in this article by The Windows Club: "Blurry Fonts or Text in Windows 8"


BLANKET SOLUTION:

Below is a more global approach that gets you a fix fast across everything. You can then go back and fine-tune when you have time.

On Windows 8, turning off the option "Smooth edges of screen fonts" in the Visual Effects dialog box improves the situation.

Win+R > control > in search box type: visual > System: Adjust the appearance & performance of windows > Visual effects tab > UNCHECK "Smooth edges of screen fonts".

enter image description here

You can see BEFORE and AFTER images below. Computer: Lenovo Ultrabook laptop running Windows 8.1 with a 1920x1080 display. Application: legacy desktop application R Statistical Computing Platform.

BEFORE

enter image description here

AFTER

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.