Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Debian (squeeze) desktop, and I need to use a D-Link 150 USB Wireless Network Adapter. So far I've done this:

$ lsusb
...
Bus 001 Device 006: ID 2001:3c18 D-Link Corp.
...

After looking for a solution in google, I found that I needed to install the following package:

firmware-ralink_0.28+squeeze1_all.deb

I've installed it, but Debian doesn't want to find the adapter. When I run lsmod, I can't find what I'm supposed to find: rt2870sta... So I load it manually: modprobe rt2870sta... when I run lsmod now there are these new lines:

Module          Size   Used by
rt2870        360987   0
crc_ccitt       1323   1 rt2870sta

But ifconfig doesn't show any new interface.

Can you point me in the right direction?


When I plug in the USB device, dmesg shows the following:

[ 4514.452959] usb 2-1.3: new high speed USB device using ehci_hcd and address 3
[ 4514.570222] usb 2-1.3: New USB device found, idVendor=2001, idProduct=3c19
[ 4514.570250] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4514.570256] usb 2-1.3: Product: 11n Adapter
[ 4514.570280] usb 2-1.3: Manufacturer: Ralink
[ 4514.570284] usb 2-1.3: SerialNumber: 1.0
[ 4514.570701] usb 2-1.3: configuration #1 chosen from 1 choice

A little more data.

I checked ifconfig, and there's not any wireless adapter detected by debian:

# ifconfig
eth0 ...
lo ...

The contents of /etc/network/interfaces is:

auto lo
iface lo inet loopback
allow-hotplug eth0
#NetworkManager#iface eth0 inet dhcp

I hope this additional data helps


More data

After running iwconfig and ifconfig -a I get the following output:

# iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
pan0      no wireless extensions.

# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:27:0e:24:c1:4d  
          inet addr:192.168.1.225  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::227:eff:fe24:c14d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1003590 errors:0 dropped:3149 overruns:0 frame:0
          TX packets:485162 errors:857 dropped:0 overruns:0 carrier:857
          collisions:22136 txqueuelen:1000 
          RX bytes:1302629169 (1.2 GiB)  TX bytes:31914674 (30.4 MiB)
          Interrupt:20 Memory:e3200000-e3220000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:56406 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56406 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10194174 (9.7 MiB)  TX bytes:10194174 (9.7 MiB)

pan0      Link encap:Ethernet  HWaddr 2a:c0:d2:a1:be:fa  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

(as you can see, I am connected to a wired network on eth0, but I'd like to get rid of the cable ;) )

I assume (though I'm not sure), that pan0 has something to do with the wireless adapter. Now, if that's right, all that remains is know how to configure it.

share|improve this question
    
Not running Debian, but perhaps firmware-ralink (0.35~bpo60+1) might be useful. –  harrymc Nov 11 '12 at 20:17
    
What is dmesg saying, when you plug-in usb? –  week Nov 11 '12 at 20:31
    
@week Just updated the post with the data you requested :-) –  Barranka Nov 12 '12 at 17:54
    
It looks like it's detected ok. Now, modprobe rt2870sta, then check if it's loaded lsmod. –  week Nov 12 '12 at 18:15
1  
Hm, I can see why it's not working now, wiki.debian.org/rt2870sta , this usb card is not among supported ones. But it's possible, that it might still work, try this procedure ha19.no/usb , simply modprobe -r rt2870sta, modprobe rt2870sta and echo 2001 3c18 > /sys/bus/usb/drivers/rt2870/new_id . Hope it will work for you. That pan0 device will probably be bluetooth device. If you manage to get it right iwconfig will show you more than no wireless extension. –  week Nov 12 '12 at 19:15

1 Answer 1

Debian is relatively well documented.

http://wiki.debian.org/WiFi
http://wiki.debian.org/WiFi/HowToUse

Install wpa_supplicant and add your network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.