Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Thomson TG789vn v2 router and a weird way ISP (ASK4, UK) wants me to use it.

They are telling me to connect their cable to Ethernet 1 slot and disable DHCP on the router.

When I do that some magic happens and the router no longer shows up in my Ethernet connection details, instead there is a 10.x.x.x address, I can no longer access neither the router nor the network share I had on it, when I try to ping either of those I am getting a "Destination host could not be reached" reply from the 10.x.x.x gateway. ISP also requires to register every newly connected device under my account on their portal.

When I plug their cable into the WAN port I end up on an error page on their webserver when I try any kind of connection.

So how do I go about it to have my network share working?

share|improve this question
What hardware does the ISP provide you? What is the device you'd be connecting to your router? – David Schwartz Nov 8 '12 at 0:06
ISP does not provide me with anything. I'm connecting a laptop, and a couple smartphones. – pandasauce Nov 8 '12 at 7:53
If the ISP doesn't provide you anything, what are you connecting to your router?! – David Schwartz Nov 8 '12 at 7:57
Ethernet socket in the wall <-> eth cable <-> router <-> my devices – pandasauce Nov 8 '12 at 9:49
Ahh, are you in a building or something with shared Internet? What does the cable come from? – David Schwartz Nov 8 '12 at 15:10
up vote 0 down vote accepted

The ISP is suggesting you use your router only as a switch. This would make sense if they already provided you a router. You don't want two routers in the same network as this causes problems with double-NAT.

You need to assign the router an IP address that's valid in the LAN range that your existing router provides (ideally outside of its DHCP range). You need to get a new IP address and default gateway on your PC as well.

You can usually figure this out by trial and error. For example, if a PC connected directly to your ISP gets assigned an IP address of and a default gateway of, you can determine that the ISP's router has an IP address of and its DHCP block probably starts with That would make a good LAN IP address for your router.

share|improve this answer
What about setting obtain via DHCP option on router? – week Nov 8 '12 at 0:16
If the router has an option to obtain its LAN IP by DHCP, then use that. But usually that option is for the WAN IP. Since you're not connecting this router to a WAN, that won't help you. – David Schwartz Nov 8 '12 at 0:22
The router web interface certainly does not allow me to set up an IP address for it let alone by DHCP and I have no clue how to do this via telnet. – pandasauce Nov 8 '12 at 8:31
It can be done but it's a real pain. You may just want to get a different router -- ideally one that can run something like Tomato or OpenWRT. – David Schwartz Nov 8 '12 at 11:31
One should absolutely not "make up" (or guess or anything else) IP addresses on a network he does not administer! Either tweak your device to get an address assigned over DHCP (or whatever protocol the ISP uses, usually it is DHCP), or ask your ISP for an address some other way. Oh, you did exactly that, I see in your own answer. :-) – David Balažic Apr 10 '15 at 11:35

Got it running finally :)

Steps were: 1. Register both router and smb MAC addresses with ISP through their web front end 2. Disconnect from the ISP 3. telnet into router

ip arpadd intf=LocalNetwork ip=<smb address supplied by isp> hwaddr=<smb share mac>
ip ipadd intf=LocalNetwork addr=<router address supplied by isp> netmask=<netmask supplied by isp>

The setup I have is a slightly modified Bridge template from MH Setup Wizards. Don't forget to enable USB controller if you have just installed the template:

pwr config usb-controller=enabled
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .