Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a heavy konsole user, and having recently discovered autossh, I'm quite happy adding new tabs using

konsole --new-tab -e autossh user@hostname

Unfortunately, Konsole's tab text is not following the remote directory and host name like my tabs do when using regular ssh.

I'd like to correct this, because it doesn't tell me the hostname to which I am connected.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

konsole can be configured to set the title differently, you can control it by adjusting your currently used profile. put a '%w' where you want your the escape sequence of your shell to appear (read 'background answer' for how to do this). the problem with 'autossh' seems to be, that it does not indicate to konsole that you are now on a 'remote' host...

konsole settings

background answer:

the title of a konsole tab (or xterm) is controled by 'escape sequencing' coming from your shell. read 'How to change the title of an xterm and put those sequences into the shell configurations of every machine you ssh to.

share|improve this answer

The reason konsole does not know we are in remote shells is because it only looks at 'ssh' commands as initializing remote shells. If I use the format ssh user@host it shows the title properly.

But I am using a wrapper script called sshr. (format: sshr host).

autossh is also a wrapper. So konsole only uses the remote command title when it sees ssh.

I have posted a bug report for konsole after not finding any info on fixing it myself.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.