Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Dell Inspiron 1520 laptop connected to my wireless broadband (UK ISP, o2) and a desktop PC which - until a few days ago - was connecting fine.

On my desktop PC I am running Windows XP and, using the XP connection UI, I can see the wireless network I want to connect to. Attempting to connect gives the error:

Windows is unable to connect to the selected network. The network may no longer be in range. Please refresh the list of available network, and try to connect again.

Trying again makes no difference.

I've rebooted, reinstalled the network drivers, reinstalled the card itself (Belkin 802.11g Network Adapter) and tried manually assigning IP addresses, neither of which have worked.

Speaking of IP addresses, running "ipconfig" in the DOS shell gives me the following error:

Media State . . . . . . . . . . . : Media Disconnected

No amount of "ipconfig/release" or "renew" makes the slightest difference.

Any ideas, folks? I'm beginning to worry about the future of my PC.

Any help appreciated.

share|improve this question

migrated from Oct 3 '09 at 2:09

This question came from our site for system and network administrators.

You'll get better responses on Serverfault is for sysadmins – MDMarra Oct 2 '09 at 23:52 – Izzy Oct 3 '09 at 1:40

An explanation might be that there is more interference for the desktop than the laptop.
This funny article suggests to change the Wireless channel to 11:
Windows is unable to connect to the selected network
as apparently the (surprising) fact is that the default channel 6 isn't as strong as 1 or 11 (!).

If not, this Microsoft article may apply :
You cannot connect to a wireless network access point that uses shared authentication

This article : Windows is unable to connect to the selected network, suggests switching to WPA2 encoding. It also suggests the following:

Besides just uninstalling the wireless utility in Add/Remove Programs, I usually uninstall the card itself in Device Manager as well, then reboot, cancel the 'hardware found' wizard, and install the latest drivers. Though I've never seen that help this particular problem. Intermittent connectivity problems, yes.

share|improve this answer

Ok some of these may be a shot in the dark but its the first things that come into my mind.

What have you done recently to make it stop working all of a sudden? Have you installed anything that may affect this? My first thought would be a firewall/antivirus that may be interfering.

I've had some problems with Zonealarm recently, so have had to completely uninstall it, just disabling it doesn't work

Under My Computer > Properties > Computer management, are all your network devices installed ok? ie there are no devices with a yellow question mark?

Under Network Connections > Network Devices, is the NIC enabled?

Failing all this, have you considered a system restore? Try to restore back a few days prior to this and see if that resolves it.

Also, I noticed you mentioned o2 Wireless, is that using one of those USB dongles? If so, thats a different ballgame, we use those at my company and they are nothing but trouble....

Hope this helps!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.