Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This appears to be a common problem on 12.04. I've tried everthing in this thread including:

sudo apt-get clean

sudo apt-get autoclean

sudo apt-get remove --purge mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5

sudo apt-get install mysql-server

I still get the same old error. Installing/starting MySql5.5 looks like this:

apt-get install -f mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
mysql-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up mysql-server-5.5 (5.5.24-0ubuntu0.12.04.1) ...
120907 21:37:15 [Note] Plugin 'FEDERATED' is disabled.
120907 21:37:15 InnoDB: The InnoDB memory heap is disabled
120907 21:37:15 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120907 21:37:15 InnoDB: Compressed tables use zlib 1.2.3.4
120907 21:37:15 InnoDB: Initializing buffer pool, size = 128.0M
120907 21:37:15 InnoDB: Completed initialization of buffer pool
120907 21:37:15 InnoDB: highest supported file format is Barracuda.
120907 21:37:15  InnoDB: Waiting for the background threads to start
120907 21:37:16 InnoDB: 1.1.8 started; log sequence number 154164236
120907 21:37:16  InnoDB: Starting shutdown...
120907 21:37:16  InnoDB: Shutdown completed; log sequence number 154164236
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.

Errors were encountered while processing:
 mysql-server-5.5
 mysql-server

In addition, dpkg-reconfigure mysql-server-5.5 returns /usr/sbin/dpkg-reconfigure: mysql-server-5.5 is broken or not fully installed

The ultimate goal here is installing and configuring Gitorious to work with Redmine but I believe the problem is isolated to Ubuntu 12.04 and MySql5.5

share|improve this question
1  
I've also tried both answers here to no avail askubuntu.com/questions/134574/… – Archonic Nov 8 '12 at 18:01
up vote 5 down vote accepted

In my case, andrewcaveman's solution did a job.

I had the same issue. Tried the apt-get clean, autoclean, remove and apt-get install mysql-server-5.5 Same error would keep coming up.

I removed everything a second time, tried again, still the same problem.

This is what worked for me, though I was doing an install and not an upgrade, so I didn't care about the existing database.

I removed all the mysql application again, then I went and deleted my /var/lib/mysql directory. Keep in mind, if you have an existing database there, you will lose it. You might want to move it to another location.

After removing that directory, I installed again and it worked perfect. So something in the /var/lib/mysql directory was my problem. See if that works for you.

source: http://ubuntuforums.org/showpost.php?p=12362816&postcount=2

share|improve this answer
    
Link-only answers are a no-no due to possible link rot in the future. Please include pertinent information in your answer. – Ƭᴇcʜιᴇ007 Nov 19 '12 at 18:06
    
This worked!!!!!!! YEAAAA – robert Dec 30 '12 at 0:24
    
this one worked for me as well (Ubuntu 13.04) – BenCes May 27 '13 at 14:23
    
It worked for me too, but in kubuntu you must first remove all mysql-server-core dependent software before it works and install it AFTER it worked – baldrs Aug 15 '13 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .