Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed a fresh copy of ArchLinux (2012-11-01) by following the installation guide.

When I boot into the new system, I am presented with a nice GRUB menu, then the loading messages. All this is fine until I get to the TTY login prompt which is completely illegible.

I tried running the setfont command but that changes the font to another illegible character set. I also tried setting the font in /etc/vconsole.conf but, again it is just gibberish, even though I can see that there is a change.

It appears no matter what font I set it to, it is not readable. I also verified that I am able to login to the system with my root password (if I look closely, I can almost make out the characters being displayed on the screen).

Here are the computer details:

Product Name: Compaq PC
Processor Type: Celeron
Processor Speed: 566/66 MHz
Memory Size: 512MB
System ROM Date: 02/11/00
System ROM Family: 686C3
Chasis Serial Number: 1X03DCV8N496

Is this an issue with the display card (since this is a very old computer) or misconfiguration?





Any ideas please?


sh-4.2# lspci | grep VGA
00:01.0 VGA Compatible controller: Intel Corporation 82810E DC-133 (CGC) Chipset Grapics Controller (rev 03)
sh-4.2# pacman -Ss xf86-video | grep installed


Interestingly, I just installed a fresh copy of Ubuntu 12.04 and the same thing happens. Everything is fine when booting from CD, but as soon as I boot into the new OS, the console is unreadable.

share|improve this question
Which graphics card do you have? – grawity Nov 8 '12 at 14:43
@grawity I'm using the built-in card. – adaptive Nov 8 '12 at 14:52
Which doesn't tell us anything at all. – grawity Nov 8 '12 at 15:18
@grawity I know that doesn't say much. I thought the machine details above would give an idea. How can I tell what the chipset of the on-board card is? – adaptive Nov 8 '12 at 15:32
@adaptive I deleted my answer since it wasn't helpful. You can post that with "lspci | grep VGA" to give us an idea. The other thing that would help is your driver, if any, you have installed "pacman -Ss xf86-video | grep installed". – nerdwaller Nov 8 '12 at 15:38

You must log in to answer this question.

Browse other questions tagged .